Jenkins LTS < 2.440.2 / Jenkins weekly < 2.444

high Nessus プラグイン ID 192307

概要

リモートのWebサーバーホストで実行されているアプリケーションは、脆弱性の影響を受けます。

説明

自己報告されたバージョン番号によると、リモートのWebサーバーで実行されているJenkinsのバージョンは、2.440.2より前のJenkins LTSまたは2.444より前のJenkins weeklyです。したがって、脆弱性の影響を受けます。

- Jetty は、Java ベースのウェブサーバーおよびサーブレットエンジンです。確立されて TCP が混雑している HTTP/2 SSL 接続は、タイムアウトすると漏洩します。攻撃者は多数の接続をこの状態にすることができ、サーバーがファイル記述子を使い果たし、最終的にサーバーが有効なクライアントからの新しい接続の受け入れを停止する可能性があります。この脆弱性は、9.4.54、10.0.20、11.0.20、および 12.0.6 でパッチされています。
(CVE-2024-22201)

Nessus はこの問題をテストしておらず、代わりにアプリケーションが自己報告するバージョン番号にのみ依存していることに注意してください。

ソリューション

Jenkins weekly をバージョン 2.444 以降に、Jenkins LTS をバージョン 2.440.2 以降にアップグレードしてください。

参考資料

https://jenkins.io/security/advisory/2024-03-20

プラグインの詳細

深刻度: High

ID: 192307

ファイル名: jenkins_2_444.nasl

バージョン: 1.1

タイプ: combined

エージェント: windows, macosx, unix

ファミリー: CGI abuses

公開日: 2024/3/20

更新日: 2024/6/4

設定: 徹底したチェックを有効にする

サポートされているセンサー: Frictionless Assessment Agent, Nessus Agent, Nessus

リスク情報

VPR

リスクファクター: Low

スコア: 3.6

CVSS v2

リスクファクター: High

基本値: 7.8

現状値: 5.8

ベクトル: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C

CVSS スコアのソース: CVE-2024-22201

CVSS v3

リスクファクター: High

基本値: 7.5

現状値: 6.5

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

現状ベクトル: CVSS:3.0/E:U/RL:O/RC:C

脆弱性情報

CPE: cpe:/a:jenkins:jenkins, cpe:/a:cloudbees:jenkins

必要な KB アイテム: installed_sw/Jenkins

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2024/3/20

脆弱性公開日: 2024/2/26

参照情報

CVE: CVE-2024-22201