Atlassian Confluence < 7.19.20 / 7.20.x < 8.5.7 (CONFSERVER-94843)

high Nessus プラグイン ID 192703

概要

リモートの Atlassian Confluence ホストにセキュリティ更新がありません。

説明

リモートホストで実行されている Atlassian Confluence Server のバージョンは、CONFSERVER-94843 アドバイザリに記載されている脆弱性の影響を受けます。

- Eclipse Jetty は、ウェブサーバーとサーブレットコンテナを提供します。11.0.0 から 11.0.15、10.0.0 から 10.0.15、および 9.0.0 から 9.4.52 では、[MetaDataBuilder.checkSize] の整数オーバーフローにより、HTTP/2 HPACK ヘッダー値がサイズ制限を超える可能性があります。[MetaDataBuilder.java] は、ヘッダー名または値がサイズ制限を超えているかどうかを判断し、制限を超えた場合は例外をスローします。しかし、length が非常に大きく、huffman が true である場合、295 行目の 4 による乗算がオーバーフローし、length は負になります。[(_size+length)] は負になり、296 行目のチェックはトリガーされません。
さらに、[MetaDataBuilder.checkSize] は、ユーザーが入力した HPACK ヘッダー値のサイズが負になることを許容しており、ユーザーが入力したサイズが後で 2 を掛けた場合に、非常に大きなバッファの割り当てにつながる可能性があります。これは、ユーザーが負の length 値 (より正確には、4/3 ファッジ係数を掛けると負になる length 値) であり、この length 値が 2 を掛けると非常に大きな正の数になる場合、ユーザーはサーバーに非常に大きなバッファを割り当てることができることを意味します。
HTTP/2 のユーザーは、リモートのサービス拒否攻撃の影響を受ける可能性があります。この問題はバージョン 11.0.16、10.0.16、および 9.4.53 で修正されています。既知の回避策はありません。(CVE-2023-36478)

Nessus はこの問題をテストしておらず、代わりにアプリケーションが自己報告するバージョン番号にのみ依存していることに注意してください。

ソリューション

Atlassian Confluence バージョン 7.19.20、8.5.7 以降にアップグレードしてください。

参考資料

https://jira.atlassian.com/browse/CONFSERVER-94843

プラグインの詳細

深刻度: High

ID: 192703

ファイル名: confluence_confserver-94843.nasl

バージョン: 1.2

タイプ: combined

エージェント: windows, macosx, unix

ファミリー: CGI abuses

公開日: 2024/3/29

更新日: 2024/6/5

設定: 徹底したチェックを有効にする

サポートされているセンサー: Nessus Agent, Nessus

リスク情報

VPR

リスクファクター: Medium

スコア: 4.4

CVSS v2

リスクファクター: High

基本値: 7.8

現状値: 6.1

ベクトル: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C

CVSS スコアのソース: CVE-2023-36478

CVSS v3

リスクファクター: High

基本値: 7.5

現状値: 6.7

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

現状ベクトル: CVSS:3.0/E:P/RL:O/RC:C

脆弱性情報

CPE: cpe:/a:atlassian:confluence

必要な KB アイテム: installed_sw/Atlassian Confluence

エクスプロイトが利用可能: true

エクスプロイトの容易さ: Exploits are available

パッチ公開日: 2024/3/7

脆弱性公開日: 2023/10/10

参照情報

CVE: CVE-2023-36478

IAVA: 2024-A-0175-S