RHEL 7 : rh-php72-php (RHSA-2019:3299)

critical Nessus プラグイン ID 193829

概要

リモートの Red Hat ホストに 1 つ以上の rh-php72-php 用セキュリティ更新プログラムがありません。

説明

リモート Redhat Enterprise Linux 7 ホストに、RHSA-2019:3299 アドバイザリに記載されている複数の脆弱性の影響を受けるパッケージがインストールされています。

- gd: 符号なし整数アンダーフロー _gdContributionsAlloc() (CVE-2016-10166)

- php: PHAR 読み取り関数におけるバッファーオーバーリード (CVE-2018-20783)

- gd: gd_color_match.c の gdImageColorMatch() におけるヒープベースのバッファオーバーフロー (CVE-2019-6977)

- php: xmlrpc_decode() 関数における無効なメモリーアクセス (CVE-2019-9020)

- php: PHAR 読み取り関数におけるヒープベースのバッファーオーバーリード (CVE-2019-9021)

- php: 細工された DNS 応答を介した負の長さの memcpy (CVE-2019-9022)

- php: mbstring 正規表現関数におけるヒープベースのバッファーオーバーリード (CVE-2019-9023)

- php: ext/xmlrpc/libxmlrpc/ base64.c 内の base64_decode_xmlrpc における領域外読み取り (CVE-2019-9024)

- php: ファイルシステムでファイルの名前を変更すると、処理中に不適切なアクセスが許可される可能性があります (CVE-2019-9637)

- php: exif_process_IFD_in_MAKERNOTE における初期化されていない読み取り (CVE-2019-9638、CVE-2019-9639)

- php: exif_process_SOFn() における無効な読み取り (CVE-2019-9640)

- php: 関数 exif_process_IFD_TAG() におけるヒープバッファーオーバーフロー (CVE-2019-11034)

- php: 関数 exif_iif_add_value() におけるヒープバッファーオーバーフロー (CVE-2019-11035)

- php: 情報漏洩を引き起こす exif_process_IFD_TAG() でのバッファーオーバーリード (CVE-2019-11036)

- gd: gdImageCreateFromXbm() 内の情報漏洩 (CVE-2019-11038)

- php: iconv_mime_decode_headers() での整数オーバーフローによる領域外読み取り (CVE-2019-11039)

- php: exif_read_data() におけるバッファーオーバーリード (CVE-2019-11040)

- php: exif_scan_thumbnail() におけるヒープバッファーオーバーリード (CVE-2019-11041)

- php: exif_process_user_comment() におけるヒープバッファーオーバーリード (CVE-2019-11042)

- php: fpm_main.c の env_path_info におけるアンダーフロー (CVE-2019-11043)

Nessus はこれらの問題をテストしておらず、代わりにアプリケーションが自己報告するバージョン番号にのみ依存していることに注意してください。

ソリューション

RHEL rh-php72-php パッケージを、RHSA-2019:3299 のガイダンスに基づいて更新してください。

参考資料

https://access.redhat.com/security/updates/classification/#critical

https://bugzilla.redhat.com/show_bug.cgi?id=1418983

https://bugzilla.redhat.com/show_bug.cgi?id=1672207

https://bugzilla.redhat.com/show_bug.cgi?id=1680545

https://bugzilla.redhat.com/show_bug.cgi?id=1685123

https://bugzilla.redhat.com/show_bug.cgi?id=1685132

https://bugzilla.redhat.com/show_bug.cgi?id=1685398

https://bugzilla.redhat.com/show_bug.cgi?id=1685404

https://bugzilla.redhat.com/show_bug.cgi?id=1685412

https://bugzilla.redhat.com/show_bug.cgi?id=1688897

https://bugzilla.redhat.com/show_bug.cgi?id=1688922

https://bugzilla.redhat.com/show_bug.cgi?id=1688934

https://bugzilla.redhat.com/show_bug.cgi?id=1688939

https://bugzilla.redhat.com/show_bug.cgi?id=1702246

https://bugzilla.redhat.com/show_bug.cgi?id=1702256

https://bugzilla.redhat.com/show_bug.cgi?id=1707299

https://bugzilla.redhat.com/show_bug.cgi?id=1724149

https://bugzilla.redhat.com/show_bug.cgi?id=1724152

https://bugzilla.redhat.com/show_bug.cgi?id=1724154

https://bugzilla.redhat.com/show_bug.cgi?id=1739459

https://bugzilla.redhat.com/show_bug.cgi?id=1739465

https://bugzilla.redhat.com/show_bug.cgi?id=1766378

http://www.nessus.org/u?971651cb

https://access.redhat.com/errata/RHSA-2019:3299

プラグインの詳細

深刻度: Critical

ID: 193829

ファイル名: redhat-RHSA-2019-3299.nasl

バージョン: 1.2

タイプ: local

エージェント: unix

公開日: 2024/4/24

更新日: 2024/4/25

サポートされているセンサー: Agentless Assessment, Frictionless Assessment Agent, Frictionless Assessment AWS, Frictionless Assessment Azure, Nessus Agent, Nessus

リスク情報

VPR

リスクファクター: Critical

スコア: 9.0

CVSS v2

リスクファクター: High

基本値: 7.5

現状値: 6.2

ベクトル: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

CVSS スコアのソース: CVE-2019-9023

CVSS v3

リスクファクター: Critical

基本値: 9.8

現状値: 9.1

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

現状ベクトル: CVSS:3.0/E:F/RL:O/RC:C

脆弱性情報

CPE: p-cpe:/a:redhat:enterprise_linux:rh-php72-php-odbc, p-cpe:/a:redhat:enterprise_linux:rh-php72-php-mbstring, p-cpe:/a:redhat:enterprise_linux:rh-php72-php, p-cpe:/a:redhat:enterprise_linux:rh-php72-php-fpm, p-cpe:/a:redhat:enterprise_linux:rh-php72-php-xmlrpc, p-cpe:/a:redhat:enterprise_linux:rh-php72-php-gmp, p-cpe:/a:redhat:enterprise_linux:rh-php72-php-enchant, p-cpe:/a:redhat:enterprise_linux:rh-php72-php-devel, p-cpe:/a:redhat:enterprise_linux:rh-php72-php-zip, p-cpe:/a:redhat:enterprise_linux:rh-php72-php-dbg, p-cpe:/a:redhat:enterprise_linux:rh-php72-php-intl, p-cpe:/a:redhat:enterprise_linux:rh-php72-php-gd, p-cpe:/a:redhat:enterprise_linux:rh-php72-php-ldap, p-cpe:/a:redhat:enterprise_linux:rh-php72-php-common, p-cpe:/a:redhat:enterprise_linux:rh-php72-php-mysqlnd, p-cpe:/a:redhat:enterprise_linux:rh-php72-php-pspell, p-cpe:/a:redhat:enterprise_linux:rh-php72-php-snmp, p-cpe:/a:redhat:enterprise_linux:rh-php72-php-bcmath, p-cpe:/a:redhat:enterprise_linux:rh-php72-php-embedded, p-cpe:/a:redhat:enterprise_linux:rh-php72-php-pdo, p-cpe:/a:redhat:enterprise_linux:rh-php72-php-process, p-cpe:/a:redhat:enterprise_linux:rh-php72-php-recode, p-cpe:/a:redhat:enterprise_linux:rh-php72-php-opcache, p-cpe:/a:redhat:enterprise_linux:rh-php72-php-soap, p-cpe:/a:redhat:enterprise_linux:rh-php72-php-json, cpe:/o:redhat:enterprise_linux:7, p-cpe:/a:redhat:enterprise_linux:rh-php72-php-xml, p-cpe:/a:redhat:enterprise_linux:rh-php72-php-cli, p-cpe:/a:redhat:enterprise_linux:rh-php72-php-dba, p-cpe:/a:redhat:enterprise_linux:rh-php72-php-pgsql

必要な KB アイテム: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list, Host/cpu

エクスプロイトが利用可能: true

エクスプロイトの容易さ: Exploits are available

パッチ公開日: 2019/11/1

脆弱性公開日: 2017/1/28

CISA の既知の悪用された脆弱性の期限日: 2022/4/15

エクスプロイト可能

Metasploit (PHP-FPM Underflow RCE)

参照情報

CVE: CVE-2016-10166, CVE-2018-20783, CVE-2019-11034, CVE-2019-11035, CVE-2019-11036, CVE-2019-11038, CVE-2019-11039, CVE-2019-11040, CVE-2019-11041, CVE-2019-11042, CVE-2019-11043, CVE-2019-6977, CVE-2019-9020, CVE-2019-9021, CVE-2019-9022, CVE-2019-9023, CVE-2019-9024, CVE-2019-9637, CVE-2019-9638, CVE-2019-9639, CVE-2019-9640

CWE: 119, 120, 122, 125, 190, 200, 266, 665, 787

RHSA: 2019:3299