RHEL 6 / 7 : rh-mysql57-mysql (RHSA-2018:3655)

high Nessus プラグイン ID 194018

概要

リモートの Red Hat ホストに 1 つ以上の rh-mysql57-mysql 用のセキュリティ更新プログラムがありません。

説明

リモート Redhat Enterprise Linux 6 / 7 ホストに、RHSA-2018:3655 アドバイザリに記載されている複数の脆弱性の影響を受けるパッケージがインストールされています。

- mysql: Server: レプリケーションの詳細不明な脆弱性 (CPU 2018 年 4 月) (CVE-2018-2755)

- mysql: Server: Security: 権限の詳細不明な脆弱性 (CPU 2018 年 4 月) (CVE-2018-2758、CVE-2018-2818)

- mysql: InnoDB の詳細不明な脆弱性 (CPU 2018 年 4 月) (CVE-2018-2759、CVE-2018-2766、CVE-2018-2777、CVE-2018-2782、CVE-2018-2784、CVE-2018-2786、CVE-2018-2787、CVE-2018-2810、CVE-2018-2819)

- mysql: クライアントプログラムの詳細不明な脆弱性 (CPU 20218 年 4 月) (CVE-2018-2761)

- mysql: Server: 接続の詳細不明な脆弱性 (CPU 2018 年 4 月) (CVE-2018-2762)

- mysql: Server: プラグ可能な認証の詳細不明の脆弱性 (CPU 2018 年 4 月) (CVE-2018-2769)

- mysql: Server: ロッキングの詳細不明な脆弱性 (CPU 2018 年 4 月) (CVE-2018-2771)

- mysql: 誰でも書き込めるディレクトリに pid ファイルが作成される可能性があります (CPU 2018 年 4 月) (CVE-2018-2773)

- mysql: Server: Optimizer の詳細不明な脆弱性 (CPU 2018 年 4 月) (CVE-2018-2775、CVE-2018-2778、CVE-2018-2779、CVE-2018-2780、CVE-2018-2781、CVE-2018-2812、CVE-2018-2816)

- mysql: Server: グループレプリケーション GCS の詳細不明な脆弱性 (CPU 2018 年 4 月) (CVE-2018-2776)

- mysql: Server: DDL の詳細不明な脆弱性 (CPU 2018 年 4 月) (CVE-2018-2813、CVE-2018-2817)

- mysql: Server: DML の詳細不明な脆弱性 (CPU 2018 年 4 月) (CVE-2018-2839)

- mysql: Server: パフォーマンススキーマの詳細不明な脆弱性 (CPU 2018 年 4 月) (CVE-2018-2846)

- mysql: Server: DDL の詳細不明な脆弱性 (CPU 2018 年 7 月) (CVE-2018-3054、CVE-2018-3077)

- mysql: Server: Security: 権限の詳細不明な脆弱性 (CPU 2018 年 7 月) (CVE-2018-3056)

- mysql: MyISAM の詳細不明な脆弱性 (CPU 2018 年 7 月) (CVE-2018-3058)

- mysql: InnoDB の詳細不明な脆弱性 (CPU 2018 年 7 月) (CVE-2018-3060、CVE-2018-3064)

- mysql: Server: DML の詳細不明な脆弱性 (CPU 2018 年 7 月) (CVE-2018-3061、CVE-2018-3065)

- mysql: Server: Memcached の詳細不明な脆弱性 (CPU 2018 年 7 月) (CVE-2018-3062)

- mysql: Server: Optimizer の詳細不明な脆弱性 (CPU 2018 年 7 月) (CVE-2018-3066)

- mysql: クライアント mysqldump の詳細不明な脆弱性 (CPU 2018 年 7 月) (CVE-2018-3070)

- mysql: 監査ログの詳細不明な脆弱性 (CPU 2018 年 7 月) (CVE-2018-3071)

- mysql: クライアントプログラムの詳細不明な脆弱性 (CPU 2018 年 7 月) (CVE-2018-3081)

- mysql: Server: パーサーの詳細不明な脆弱性 (CPU 2018 年 10 月) (CVE-2018-3133、CVE-2018-3155)

- mysql: InnoDB の詳細不明な脆弱性 (CPU 2018 年 10 月) (CVE-2018-3143、CVE-2018-3156、CVE-2018-3162、CVE-2018-3173、CVE-2018-3185、CVE-2018-3200、CVE-2018-3251、CVE-2018-3277、CVE-2018-3284)

- mysql: Server: Security: 監査の詳細不明な脆弱性 (CPU 2018 年 10 月) (CVE-2018-3144)

- mysql: Server: パーティションの詳細不明な脆弱性 (CPU 2018 年 10 月) (CVE-2018-3161、CVE-2018-3171)

- mysql: mysql ユーザーが所有する pidfile からの pid を使用した、root 権限で kill を呼び出す Init スクリプト (CPU 2018 年 10 月) (CVE-2018-3174)

- mysql: Server: Optimizer の詳細不明な脆弱性 (CPU 2018 年 10 月) (CVE-2018-3187)

- mysql: Server: マージの詳細不明な脆弱性 (CPU 2018 年 10 月) (CVE-2018-3247)

- mysql: Server: Memcached の詳細不明な脆弱性 (CPU 2018 年 10 月) (CVE-2018-3276)

- mysql: Server: RBR の詳細不明な脆弱性 (CPU 2018 年 10 月) (CVE-2018-3278)

- mysql: Server: ストレージエンジンの詳細不明な脆弱性 (CPU 2018 年 10 月) (CVE-2018-3282)

- mysql: Server: ロギングの詳細不明な脆弱性 (CPU 2018 年 10 月) (CVE-2018-3283)

- mysql: Server: レプリケーションの詳細不明な脆弱性 (CPU 2019 年 7 月) (CVE-2019-2731)

Nessus はこれらの問題をテストしておらず、代わりにアプリケーションが自己報告するバージョン番号にのみ依存していることに注意してください。

ソリューション

RHEL rh-mysql57-mysql パッケージを、RHSA-2018:3655 のガイダンスに基づいて更新してください。

参考資料

https://access.redhat.com/security/updates/classification/#moderate

https://bugzilla.redhat.com/show_bug.cgi?id=1568921

https://bugzilla.redhat.com/show_bug.cgi?id=1568922

https://bugzilla.redhat.com/show_bug.cgi?id=1568923

https://bugzilla.redhat.com/show_bug.cgi?id=1568924

https://bugzilla.redhat.com/show_bug.cgi?id=1568925

https://bugzilla.redhat.com/show_bug.cgi?id=1568926

https://bugzilla.redhat.com/show_bug.cgi?id=1568927

https://bugzilla.redhat.com/show_bug.cgi?id=1568931

https://bugzilla.redhat.com/show_bug.cgi?id=1568932

https://bugzilla.redhat.com/show_bug.cgi?id=1568934

https://bugzilla.redhat.com/show_bug.cgi?id=1568936

https://bugzilla.redhat.com/show_bug.cgi?id=1568937

https://bugzilla.redhat.com/show_bug.cgi?id=1568938

https://bugzilla.redhat.com/show_bug.cgi?id=1568940

https://bugzilla.redhat.com/show_bug.cgi?id=1568941

https://bugzilla.redhat.com/show_bug.cgi?id=1602354

https://bugzilla.redhat.com/show_bug.cgi?id=1602355

https://bugzilla.redhat.com/show_bug.cgi?id=1602356

https://bugzilla.redhat.com/show_bug.cgi?id=1602357

https://bugzilla.redhat.com/show_bug.cgi?id=1602359

https://bugzilla.redhat.com/show_bug.cgi?id=1602360

https://bugzilla.redhat.com/show_bug.cgi?id=1602364

https://bugzilla.redhat.com/show_bug.cgi?id=1568942

https://bugzilla.redhat.com/show_bug.cgi?id=1568943

https://bugzilla.redhat.com/show_bug.cgi?id=1568944

https://bugzilla.redhat.com/show_bug.cgi?id=1568945

https://bugzilla.redhat.com/show_bug.cgi?id=1568946

https://bugzilla.redhat.com/show_bug.cgi?id=1568949

https://bugzilla.redhat.com/show_bug.cgi?id=1568950

https://bugzilla.redhat.com/show_bug.cgi?id=1568951

https://bugzilla.redhat.com/show_bug.cgi?id=1568953

https://bugzilla.redhat.com/show_bug.cgi?id=1568954

https://bugzilla.redhat.com/show_bug.cgi?id=1568955

https://bugzilla.redhat.com/show_bug.cgi?id=1568956

https://bugzilla.redhat.com/show_bug.cgi?id=1568957

https://bugzilla.redhat.com/show_bug.cgi?id=1568958

https://bugzilla.redhat.com/show_bug.cgi?id=1602365

https://bugzilla.redhat.com/show_bug.cgi?id=1602366

https://bugzilla.redhat.com/show_bug.cgi?id=1602369

https://bugzilla.redhat.com/show_bug.cgi?id=1602370

https://bugzilla.redhat.com/show_bug.cgi?id=1602375

https://bugzilla.redhat.com/show_bug.cgi?id=1602424

https://bugzilla.redhat.com/show_bug.cgi?id=1640307

https://bugzilla.redhat.com/show_bug.cgi?id=1640308

https://bugzilla.redhat.com/show_bug.cgi?id=1640310

https://bugzilla.redhat.com/show_bug.cgi?id=1640312

https://bugzilla.redhat.com/show_bug.cgi?id=1640316

https://bugzilla.redhat.com/show_bug.cgi?id=1640317

https://bugzilla.redhat.com/show_bug.cgi?id=1640318

https://bugzilla.redhat.com/show_bug.cgi?id=1640319

https://bugzilla.redhat.com/show_bug.cgi?id=1640320

https://bugzilla.redhat.com/show_bug.cgi?id=1640321

https://bugzilla.redhat.com/show_bug.cgi?id=1640322

https://bugzilla.redhat.com/show_bug.cgi?id=1640324

https://bugzilla.redhat.com/show_bug.cgi?id=1640325

https://bugzilla.redhat.com/show_bug.cgi?id=1640326

https://bugzilla.redhat.com/show_bug.cgi?id=1640331

https://bugzilla.redhat.com/show_bug.cgi?id=1640332

https://bugzilla.redhat.com/show_bug.cgi?id=1640333

https://bugzilla.redhat.com/show_bug.cgi?id=1640334

https://bugzilla.redhat.com/show_bug.cgi?id=1640335

https://bugzilla.redhat.com/show_bug.cgi?id=1640337

https://bugzilla.redhat.com/show_bug.cgi?id=1640340

http://www.nessus.org/u?36699e48

https://access.redhat.com/errata/RHSA-2018:3655

プラグインの詳細

深刻度: High

ID: 194018

ファイル名: redhat-RHSA-2018-3655.nasl

バージョン: 1.0

タイプ: local

エージェント: unix

公開日: 2024/4/27

更新日: 2024/4/27

サポートされているセンサー: Frictionless Assessment AWS, Frictionless Assessment Azure, Frictionless Assessment Agent, Nessus Agent, Agentless Assessment, Nessus

リスク情報

VPR

リスクファクター: Medium

スコア: 6.5

CVSS v2

リスクファクター: Medium

基本値: 5.5

現状値: 4.1

ベクトル: CVSS2#AV:N/AC:L/Au:S/C:N/I:P/A:P

CVSS スコアのソース: CVE-2019-2731

CVSS v3

リスクファクター: High

基本値: 7.7

現状値: 6.7

ベクトル: CVSS:3.0/AV:L/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:H

現状ベクトル: CVSS:3.0/E:U/RL:O/RC:C

CVSS スコアのソース: CVE-2018-2755

脆弱性情報

CPE: cpe:/o:redhat:enterprise_linux:6, cpe:/o:redhat:enterprise_linux:7, p-cpe:/a:redhat:enterprise_linux:rh-mysql57-mysql, p-cpe:/a:redhat:enterprise_linux:rh-mysql57-mysql-common, p-cpe:/a:redhat:enterprise_linux:rh-mysql57-mysql-config, p-cpe:/a:redhat:enterprise_linux:rh-mysql57-mysql-devel, p-cpe:/a:redhat:enterprise_linux:rh-mysql57-mysql-errmsg, p-cpe:/a:redhat:enterprise_linux:rh-mysql57-mysql-server, p-cpe:/a:redhat:enterprise_linux:rh-mysql57-mysql-test

必要な KB アイテム: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list, Host/cpu

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2018/11/26

脆弱性公開日: 2018/4/17

参照情報

CVE: CVE-2018-2755, CVE-2018-2758, CVE-2018-2759, CVE-2018-2761, CVE-2018-2762, CVE-2018-2766, CVE-2018-2769, CVE-2018-2771, CVE-2018-2773, CVE-2018-2775, CVE-2018-2776, CVE-2018-2777, CVE-2018-2778, CVE-2018-2779, CVE-2018-2780, CVE-2018-2781, CVE-2018-2782, CVE-2018-2784, CVE-2018-2786, CVE-2018-2787, CVE-2018-2810, CVE-2018-2812, CVE-2018-2813, CVE-2018-2816, CVE-2018-2817, CVE-2018-2818, CVE-2018-2819, CVE-2018-2839, CVE-2018-2846, CVE-2018-3054, CVE-2018-3056, CVE-2018-3058, CVE-2018-3060, CVE-2018-3061, CVE-2018-3062, CVE-2018-3064, CVE-2018-3065, CVE-2018-3066, CVE-2018-3070, CVE-2018-3071, CVE-2018-3077, CVE-2018-3081, CVE-2018-3133, CVE-2018-3143, CVE-2018-3144, CVE-2018-3155, CVE-2018-3156, CVE-2018-3161, CVE-2018-3162, CVE-2018-3171, CVE-2018-3173, CVE-2018-3174, CVE-2018-3185, CVE-2018-3187, CVE-2018-3200, CVE-2018-3247, CVE-2018-3251, CVE-2018-3276, CVE-2018-3277, CVE-2018-3278, CVE-2018-3282, CVE-2018-3283, CVE-2018-3284, CVE-2019-2731

CWE: 121

RHSA: 2018:3655