PHP < 4.4.1 / 5.0.6 の複数の脆弱性

high Nessus プラグイン ID 20111

概要

リモート Web サーバーが使用するバージョンの PHP は、複数の欠陥の影響を受けます。

説明

バナーによると、リモートホストにインストールされている PHP のバージョンは 4.4.1 または 5.0.6 より前です。このようなバージョンは、ファイルアップロード処理コードの弱点と、「extract()」および「import_request_variables()」関数の弱点により、「$GLOBALS」スーパーグローバル変数を上書きから保護できません。影響を受けるホストの PHP アプリケーションの特性に応じて、この問題の悪用により、任意のコードの実行を含む、任意の回数の攻撃につながる可能性があります。

さらに、これらのバージョンにより、攻撃者が、特定のバージョンの PCRE ライブラリでの整数オーバーフロー欠陥を悪用し、構成で明示的に無効になっていても PHP の「register_globals」の設定を有効にして、PHP の「phpinfo()」関数に関係するクロスサイトスクリプティング攻撃を開始できることがあります。

ソリューション

PHP バージョン 4.4.1 / 5.0.6 または以降にアップグレードしてください。

関連情報

http://www.hardened-php.net/advisory_182005.77.html

http://www.hardened-php.net/advisory_192005.78.html

http://www.hardened-php.net/advisory_202005.79.html

http://www.php.net/release_4_4_1.php

プラグインの詳細

深刻度: High

ID: 20111

ファイル名: php_4_4_1.nasl

バージョン: 1.25

タイプ: remote

ファミリー: CGI abuses

公開日: 2005/11/1

更新日: 2022/4/11

構成: 徹底的なチェックを有効にする

リスク情報

VPR

リスクファクター: Medium

スコア: 6.7

CVSS v2

リスクファクター: High

Base Score: 7.5

Temporal Score: 5.9

ベクトル: AV:N/AC:L/Au:N/C:P/I:P/A:P

現状ベクトル: E:POC/RL:OF/RC:C

脆弱性情報

CPE: cpe:/a:php:php

必要な KB アイテム: www/PHP

エクスプロイトの容易さ: No exploit is required

脆弱性公開日: 2005/8/20

参照情報

CVE: CVE-2002-0229, CVE-2005-2491, CVE-2005-3388, CVE-2005-3389, CVE-2005-3390

BID: 14620, 15248, 15249, 15250

CWE: 20, 74, 79, 442, 629, 711, 712, 722, 725, 750, 751, 800, 801, 809, 811, 864, 900, 928, 931, 990