PHP < 4.4.3 / 5.1.4 の複数の脆弱性

high Nessus プラグイン ID 22268

概要

リモート Web サーバーが使用するバージョンの PHP は、複数の欠陥の影響を受けます。

説明

バナーによると、リモートホストにインストールされている PHP のバージョンは、4.4.3 / 5.1.4 より前です。このようなバージョンは、バッファオーバーフロー、ヒープ破損、および変数が「unset()」の呼び出し後も存在することがある欠陥などの、いくつかの問題の影響を受けることがあります。

ソリューション

PHP バージョン 4.4.3 / 5.1.4 または以降にアップグレードしてください。

関連情報

http://www.nessus.org/u?a7553cd8

http://www.nessus.org/u?ccaf872d

https://www.securityfocus.com/archive/1/archive/1/442437/100/0/threaded

http://us3.php.net/releases/4_4_3.php

http://us3.php.net/releases/5_1_3.php

http://www.php.net/release_5_1_4.php

プラグインの詳細

深刻度: High

ID: 22268

ファイル名: php_4_4_3.nasl

バージョン: 1.26

タイプ: remote

ファミリー: CGI abuses

公開日: 2006/8/25

更新日: 2022/4/11

構成: 徹底的なチェックを有効にする

リスク情報

VPR

リスクファクター: Medium

スコア: 6

CVSS v2

リスクファクター: High

Base Score: 9.3

Temporal Score: 7.3

ベクトル: AV:N/AC:M/Au:N/C:C/I:C/A:C

現状ベクトル: E:POC/RL:OF/RC:C

脆弱性情報

CPE: cpe:/a:php:php

必要な KB アイテム: www/PHP

エクスプロイトの容易さ: No exploit is required

パッチ公開日: 2006/8/3

脆弱性公開日: 2006/3/28

参照情報

CVE: CVE-2006-0996, CVE-2006-1490, CVE-2006-1494, CVE-2006-1608, CVE-2006-1990, CVE-2006-1991, CVE-2006-2563, CVE-2006-2660, CVE-2006-3011, CVE-2006-3016, CVE-2006-3017, CVE-2006-3018, CVE-2006-4433

BID: 17296, 17362, 17439, 17843, 18116, 18645, 49634

CWE: 79