ProFTPD < 1.3.0aの複数の脆弱性

critical Nessus プラグイン ID 27055

概要

リモートFTPサーバーは、複数の脆弱性の影響を受けます。

説明

UnixおよびLinux用の無料のFTPサーバーであるProFTPDが、リモートホストで使用されています。

バナーによると、リモートホストにインストールされているProFTPDのバージョンは1.3.0aより前です。そのため、以下のいずれかの脆弱性の影響を受ける可能性があります。

-「sreplace」関数にoff-by-one文字列操作の欠陥が存在します。(CVE-2006-5815)

- mod_tlsモジュールの「tls_x509_name_oneline」関数に、データ長引数に関するバッファオーバーフローが存在します。(CVE-2006-6170)

-「CommandBufferSize」が構成ファイルで指定されているときにバッファサイズ制限を適切に設定できないことによる、off-by-twoバッファオーバーフローが存在します。この問題は開発者によって議論されています。
(CVE-2006-6171)

攻撃者が、この問題を利用して、影響を受けるサービスをクラッシュさせたり、リモートで任意のコードを実行させたりする可能性があります。これは、アプリケーションが動作している権限の対象になります。

ソリューション

ProFTPDバージョン1.3.0a以降にアップグレードしてください。

関連情報

https://seclists.org/bugtraq/2006/Nov/315

https://www.securityfocus.com/archive/1/452760/30/0/threaded

プラグインの詳細

深刻度: Critical

ID: 27055

ファイル名: proftpd_1_3_0_a.nasl

バージョン: 1.24

タイプ: remote

ファミリー: FTP

公開日: 2007/10/15

更新日: 2018/11/15

構成: パラノイドモードの有効化

リスク情報

VPR

リスクファクター: High

スコア: 7.4

CVSS v2

リスクファクター: Critical

Base Score: 10

Temporal Score: 8.3

ベクトル: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

現状ベクトル: CVSS2#E:F/RL:OF/RC:C

脆弱性情報

CPE: cpe:2.3:a:proftpd:proftpd:*:*:*:*:*:*:*:*

必要な KB アイテム: Settings/ParanoidReport, ftp/proftpd

エクスプロイトが利用可能: true

エクスプロイトの容易さ: Exploits are available

脆弱性公開日: 2006/11/10

エクスプロイト可能

Metasploit (ProFTPD 1.2 - 1.3.0 sreplace Buffer Overflow (Linux))

参照情報

CVE: CVE-2006-5815, CVE-2006-6170, CVE-2006-6171

BID: 20992

CWE: 119