PHP < 4.4.8 の複数の脆弱性

high Nessus プラグイン ID 29833

概要

リモート Web サーバーが使用するバージョンの PHP は、複数の問題の影響を受けます。

説明

バナーによると、リモートホストにインストールされているPHPのバージョンは4.4.8より前です。このようなバージョンは、「chunk_split」、「strcspn」、および「strspn」関数に関連する整数オーバーフローや「safe_mode」/「open_basedir」のバイパスを含む、いくつかの問題の影響を受ける可能性があります。

ソリューション

PHPバージョン4.4.8以降にアップグレードしてください。

関連情報

http://www.php.net/releases/4_4_8.php

プラグインの詳細

深刻度: High

ID: 29833

ファイル名: php_4_4_8.nasl

バージョン: 1.22

タイプ: remote

ファミリー: CGI abuses

公開日: 2008/1/3

更新日: 2022/4/11

構成: 徹底的なチェックを有効にする

リスク情報

VPR

リスクファクター: Medium

スコア: 6.6

CVSS v2

リスクファクター: High

Base Score: 7.5

Temporal Score: 5.9

ベクトル: AV:N/AC:L/Au:N/C:P/I:P/A:P

現状ベクトル: E:POC/RL:OF/RC:C

脆弱性情報

CPE: cpe:/a:php:php

必要な KB アイテム: www/PHP

エクスプロイトの容易さ: No exploit is required

パッチ公開日: 2008/1/3

脆弱性公開日: 2007/8/30

参照情報

CVE: CVE-2007-3378, CVE-2007-3799, CVE-2007-3997, CVE-2007-4657, CVE-2007-4658, CVE-2008-0145, CVE-2008-2108

BID: 24661, 49631

CWE: 20, 119, 189, 264