PHP < 4.4.9 の複数の脆弱性

high Nessus プラグイン ID 33849

概要

リモート Web サーバーが使用するバージョンの PHP は、複数の問題の影響を受けます。

説明

バナーによると、リモートホストにインストールされている PHP のバージョンは 4.4.9 より前です。このようなバージョンは、以下の複数のセキュリティ問題の影響を受けることがあります。

- バージョン 7.7 によって修正済みのバンドルされた PCRE ライブラリに、未特定の問題があります。

- 「ext/gd/gd.c」の「imageloadfont()」関数のバッファオーバーフローは、特別に作り上げられたフォントが与えられたときにトリガできます。(CVE-2008-3658)

- 内部「memnstr()」関数にバッファオーバーフローがあり、「explode()」としてユーザースペースに漏洩されます。
(CVE-2008-3659)

- ファイル名に 2 つのドットが含まれているとき、サービス拒否の脆弱性があります。(CVE-2008-3660)

- curl 拡張での「open_basedir」処理の問題。

- 「.htaccess」で設定された「mbstring.func_overload」は、グローバルになります。(CVE-2009-0754)

リリースアナウンスが、これは PHP 4.4 シリーズの最後のリリースであると述べていることに、注意してください。

ソリューション

PHP バージョン 4.4.9 または以降にアップグレードしてください。

関連情報

https://www.openwall.com/lists/oss-security/2008/08/08/2

http://www.php.net/releases/4_4_9.php

http://www.php.net/ChangeLog-4.php#4.4.9

https://bugs.php.net/bug.php?id=27421

プラグインの詳細

深刻度: High

ID: 33849

ファイル名: php_4_4_9.nasl

バージョン: 1.28

タイプ: remote

ファミリー: CGI abuses

公開日: 2008/8/8

更新日: 2022/4/11

構成: 徹底的なチェックを有効にする

リスク情報

VPR

リスクファクター: Medium

スコア: 5.9

CVSS v2

リスクファクター: High

Base Score: 7.5

Temporal Score: 5.9

ベクトル: AV:N/AC:L/Au:N/C:P/I:P/A:P

現状ベクトル: E:POC/RL:OF/RC:C

脆弱性情報

CPE: cpe:/a:php:php

必要な KB アイテム: www/PHP

エクスプロイトの容易さ: No exploit is required

参照情報

CVE: CVE-2007-4850, CVE-2008-3658, CVE-2008-3659, CVE-2008-3660, CVE-2009-0754

BID: 27413, 30649, 31612, 33542

SECUNIA: 31409

CWE: 20, 119, 134, 264