MySQL Enterprise Server 5.0 < 5.0.70 の権限バイパス

medium Nessus プラグイン ID 34727

概要

リモートデータベースサーバーは、権限バイパス攻撃を受けやすくなっています。

説明

リモートホストにインストールされている MySQL Enterprise Server 5.0 のバージョンは、5.0.70 より前です。このようなバージョンでは、ローカルユーザーは、「データディレクトリ」および「インデックスディレクトリ」オプションを使用して MyISAM テーブルを作成することで権限を回避して、アプリケーションのデータディレクトリの既存のテーブルファイルを上書きできます。

この問題は、バージョン 5.0.60 で対処されたものと考えられていましたが、修正が不完全であったことに注意してください。

ソリューション

MySQL Enterprise バージョン 5.0.70 または以降にアップグレードしてください。

関連情報

http://bugs.mysql.com/bug.php?id=32167

http://dev.mysql.com/doc/refman/5.0/en/news-5-0-70.html

https://www.openwall.com/lists/oss-security/2008/09/09/20

https://www.openwall.com/lists/oss-security/2008/09/16/3

プラグインの詳細

深刻度: Medium

ID: 34727

ファイル名: mysql_es_5_0_70.nasl

バージョン: 1.15

タイプ: remote

ファミリー: Databases

公開日: 2008/11/9

更新日: 2018/11/15

リスク情報

VPR

リスクファクター: Medium

スコア: 5.5

CVSS v2

リスクファクター: Medium

Base Score: 4.6

Temporal Score: 3.4

ベクトル: AV:L/AC:L/Au:N/C:P/I:P/A:P

現状ベクトル: E:U/RL:OF/RC:C

脆弱性情報

CPE: cpe:/a:mysql:mysql

エクスプロイトの容易さ: No known exploits are available

参照情報

CVE: CVE-2008-2079, CVE-2008-4098

BID: 29106

CWE: 59, 264