PHP 5 < 5.2.7 の複数の脆弱性

high Nessus プラグイン ID 35043

概要

リモート Web サーバーが使用するバージョンの PHP は、複数の脆弱性の影響を受けます。

説明

バナーによると、リモートホストにインストールされている PHP のバージョンは 5.2.7 より前です。そのため、以下の複数の脆弱性の影響を受けます。

- バンドルされた PCRE ライブラリにバッファオーバーフロー欠陥があり、これによってサービス拒否攻撃が可能になります。
(CVE-2008-2371)

- 「posix_access」、「chdir」、「ftok」などの関数に複数のディレクトリトラバーサル脆弱性があり、リモート攻撃者は、「safe_mode」制限をバイパスできます。(CVE-2008-2665 および CVE-2008-2666)。

- 「php_imap.c」でのバッファオーバーフロー欠陥は、旧式の API 呼び出しの使用により、長いメッセージヘッダーを処理する際にトリガされることがあります。これを悪用して、サービス拒否を引き起こすことや、任意のコードを実行することができます。
(CVE-2008-2829)

- 「ext/gd/gd.c」の「imageloadfont」関数でのバッファオーバーフローは、特別に作り上げられたフォントが与えられたときに、トリガできます。これを悪用して、サービス拒否を引き起こすことや、任意のコードを実行することができます。(CVE-2008-3658)

- PHP の内部関数「memnstr」にバッファオーバーフロー欠陥があり、「explode」関数に対する区切り記号引数を使用して、攻撃者がこれを悪用できます。これを悪用して、サービス拒否を引き起こすことや、任意のコードを実行することができます。(CVE-2008-3659)

- PHP を FastCGI モジュールとして使用する場合、ファイル名の拡張子に複数のドットが先行するファイルをリクエストすることによって、攻撃者がサービス拒否を引き起こすことがあります。
(CVE-2008-3660)

- mbstring 拡張でのヒープベースのバッファオーバーフロー欠陥は、Unicode 変換中に処理されない HTML エンティティが含まれている、特別に作り上げられた文字列によって、トリガできます。これを悪用して、任意のコードを実行できます(CVE-2008-5557)

- PHP が Apache モジュールとして使用されているとき、グローバル変数「page_uid」および「page_gid」の不適切な初期化により、SAPI「php_getuid」関数のオーバーロードによるセキュリティ制限のバイパスがが可能になります。(CVE-2008-5624)

- 「safe_mode」が「httpd.conf」での「php_admin_flag」設定によって有効になっている場合、PHP は正しい制限を行いません。これにより攻撃者は、「.htaccess」に、特別に作り上げられた「php_value」エントリを配置することで、任意のファイルに書き込めます。
(CVE-2008-5625)

- ZipArchive 拡張の「ZipArchive::extractTo」関数は、ファイル名からのディレクトリトラバーサルシーケンスをフィルタリングできません。攻撃者は、これを悪用して、任意のファイルに
書き込めます。(CVE-2008-5658)

- 限られた状況下で、攻撃者は、無効な引数で「dba_replace」関数を呼び出す際に、ファイルの切り捨てを引き起こせます。(CVE-2008-7068)

- ユーザー入力の検証が不適切であるため、「xmlrpc.c」内の関数「date_from_ISO8601」にバッファオーバーフローエラーがあります。
これをリモート攻撃者が悪用して、サービス拒否を引き起こすことや、任意のコードを実行することができます。
(CVE-2014-8626)

ソリューション

PHP バージョン 5.2.8 または以降にアップグレードしてください。

バージョン 5.2.7 での回帰のため、そのバージョンが配布から削除されているため、「magic_quotes_gpc」設定がオンに設定されていてもオフのままであることに、注意してください。

関連情報

http://cxsecurity.com/issue/WLB-2008110041

http://cxsecurity.com/issue/WLB-2008110058

http://cxsecurity.com/issue/WLB-2008120011

https://seclists.org/fulldisclosure/2008/Jun/237

https://seclists.org/fulldisclosure/2008/Jun/238

https://www.openwall.com/lists/oss-security/2008/08/08/2

https://www.openwall.com/lists/oss-security/2008/08/13/8

https://seclists.org/fulldisclosure/2008/Nov/674

https://seclists.org/fulldisclosure/2008/Dec/90

https://bugs.php.net/bug.php?id=42862

https://bugs.php.net/bug.php?id=45151

https://bugs.php.net/bug.php?id=45722

http://www.php.net/releases/5_2_7.php

http://www.php.net/ChangeLog-5.php#5.2.7

プラグインの詳細

深刻度: High

ID: 35043

ファイル名: php_5_2_7.nasl

バージョン: 1.32

タイプ: remote

ファミリー: CGI abuses

公開日: 2008/12/5

更新日: 2022/4/11

リスク情報

VPR

リスクファクター: Medium

スコア: 6.7

CVSS v2

リスクファクター: High

Base Score: 7.5

Temporal Score: 5.9

ベクトル: AV:N/AC:L/Au:N/C:P/I:P/A:P

現状ベクトル: E:POC/RL:OF/RC:C

脆弱性情報

CPE: cpe:/a:php:php

必要な KB アイテム: www/PHP

エクスプロイトの容易さ: No exploit is required

パッチ公開日: 2008/12/4

脆弱性公開日: 2008/6/19

参照情報

CVE: CVE-2008-2371, CVE-2008-2665, CVE-2008-2666, CVE-2008-2829, CVE-2008-3658, CVE-2008-3659, CVE-2008-3660, CVE-2008-5557, CVE-2008-5624, CVE-2008-5625, CVE-2008-5658, CVE-2008-7068, CVE-2014-8626

BID: 29796, 29797, 29829, 30087, 30649, 31612, 32383, 32625, 32688, 32948, 70928

CWE: 20, 22, 119, 264