Serv-U < 9.1.0.0

high Nessus プラグイン ID 42934

概要

リモート FTP サーバーは、複数の脆弱性の影響を受けます。

説明

バナーによると、インストールされている Serv-U のバージョンは、9.1.0.0 より前です。このため、以下の問題の影響を受けます。

- セッションクッキーを解析するときの Web 管理インターフェイスの境界エラーにより、スタックベースのバッファオーバーフローが発生することがあります。(CVE-2009-4873)

- TEA 復号アルゴリズムの境界エラーにより、長い 16 進数文字列を解析するときにスタックベースのバッファオーバーフローが発生することがあります。(CVE-2009-4006)

ソリューション

Serv-U バージョン 9.1.0.0 または以降にアップグレードしてください。

関連情報

http://www.rangos.de/ServU-ADV.txt

https://secuniaresearch.flexerasoftware.com/secunia_research/2009-46/

https://support.solarwinds.com/Success_Center/Serv-U_Managed_File_Transfer_Serv-U_FTP_Server/Serv-U_Documentation/release_notes

プラグインの詳細

深刻度: High

ID: 42934

ファイル名: servu_9_1_0_0.nasl

バージョン: 1.16

タイプ: remote

ファミリー: FTP

公開日: 2009/11/30

更新日: 2022/4/11

構成: 徹底的なチェックを有効にする

リスク情報

VPR

リスクファクター: High

スコア: 7.4

CVSS v2

リスクファクター: High

Base Score: 9

Temporal Score: 7.4

ベクトル: AV:N/AC:L/Au:S/C:C/I:C/A:C

現状ベクトル: E:F/RL:OF/RC:C

脆弱性情報

CPE: cpe:/a:serv-u:serv-u

必要な KB アイテム: ftp/servu

エクスプロイトが利用可能: true

エクスプロイトの容易さ: Exploits are available

パッチ公開日: 2009/11/17

脆弱性公開日: 2009/11/17

エクスプロイト可能

Core Impact

Metasploit (Rhinosoft Serv-U Session Cookie Buffer Overflow)

参照情報

CVE: CVE-2009-4006, CVE-2009-4873

BID: 36895, 37051

SECUNIA: 37228

CWE: 119