SuSE 10 セキュリティ更新:poppler(ZYPP パッチ番号 6751)

high Nessus プラグイン ID 43621

言語:

概要

リモート SuSE 10 ホストにセキュリティ関連のパッチがありません。

説明

この poppler の更新は、2 つのセキュリティ問題を修正します。

- GPdf、kdegraphics KPDF、CUPS pdftops、および teTex で使用される 3.02pl4 以前の Xpdf 3.x および 0.12.1 以前の Poppler における Xref.cc の ObjectStream::ObjectStream 関数の整数オーバーフローにより、リモートの攻撃者がヒープベースのバッファオーバーフローを発生させるように細工された PDF ドキュメントを通して任意のコードを実行する場合があります。
(CVE-2009-3608)

- 攻撃者が利用してメモリを破損させたり、コードを実行する可能性のある FoFiType1::parse() のインデックスエラーが修正されました。(CVE-2009-4035)

ソリューション

ZYPP パッチ番号 6751 を適用してください。

関連情報

http://support.novell.com/security/cve/CVE-2009-3608.html

http://support.novell.com/security/cve/CVE-2009-4035.html

プラグインの詳細

深刻度: High

ID: 43621

ファイル名: suse_poppler-6751.nasl

バージョン: 1.12

タイプ: local

エージェント: unix

公開日: 2010/1/3

更新日: 2021/1/14

サポートされているセンサー: Nessus Agent

リスク情報

VPR

リスクファクター: Medium

スコア: 5.9

CVSS v2

リスクファクター: High

Base Score: 9.3

ベクトル: AV:N/AC:M/Au:N/C:C/I:C/A:C

脆弱性情報

CPE: cpe:/o:suse:suse_linux

必要な KB アイテム: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

パッチ公開日: 2009/12/21

参照情報

CVE: CVE-2009-3608, CVE-2009-4035

CWE: 94, 189