OpenSSL < 0.9.8o / 1.0.0a の複数の脆弱性

high Nessus プラグイン ID 46801

概要

リモート Web サーバーに SSL 関連の脆弱性があります。

説明

バナーによると、リモート Web サーバーで 0.9.8o / 1.0.0a より前のバージョンの OpenSSL が実行されています。このようなバージョンには以下の脆弱性があります。

- OriginatorInfo 要素が含まれた Cryptographic Message Syntax 構造の誤処理により、データが無効なメモリアドレスに書き込まれたり、メモリが 2 回解放される可能性があります。(CVE-2010-0742)

- RSA キーに対して検証の復元が失敗したとき、未定義の長さの初期化されていないバッファが返されます。これにより、攻撃者が、関数 EVP_PKEY_verify_recover() を呼び出すアプリケーションの鍵チェックをバイパスすることが可能です。注意:この関数は、OpenSSLcode 自体によっては使用されません。(CVE-2010-1633)

ソリューション

OpenSSL 0.9.8o / 1.0.0a または以降にアップグレードしてください。

関連情報

https://www.openssl.org/news/secadv/20100601.txt

プラグインの詳細

深刻度: High

ID: 46801

ファイル名: openssl_1_0_0a.nasl

バージョン: 1.10

タイプ: remote

ファミリー: Web Servers

公開日: 2010/6/3

更新日: 2018/7/16

構成: パラノイドモードの有効化

リスク情報

VPR

リスクファクター: High

スコア: 7.4

CVSS v2

リスクファクター: High

Base Score: 7.5

Temporal Score: 5.5

ベクトル: AV:N/AC:L/Au:N/C:P/I:P/A:P

現状ベクトル: E:U/RL:OF/RC:C

脆弱性情報

CPE: cpe:/a:openssl:openssl

必要な KB アイテム: Settings/ParanoidReport

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2010/6/1

脆弱性公開日: 2010/6/1

参照情報

CVE: CVE-2010-0742, CVE-2010-1633

BID: 40502, 40503

Secunia: 40024