Apache Tomcat < 6.0.18 の複数の脆弱性

medium Nessus プラグイン ID 47578
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモートの Apache Tomcat サービスは、複数の脆弱性の影響を受けることがあります。

説明

自己報告されたバージョン番号によると、リモートホストでリッスンしているApache Tomcat は、Tomcat 6.0.18 より前のバージョンであり、そのために複数の脆弱性の影響を受けることがあります。

- リモートにインストールされている Apache Tomcat は、クロスサイトスクリプティング攻撃に脆弱です。不適切な入力検証により、リモートの攻撃者が任意のスクリプトコードまたは HTML を、HttpServletResponse.sendError メソッドで使用されるメッセージ引数に注入できます。(CVE-2008-1232)

- ホストマネージャアプリケーションにクロスサイトスクリプティング脆弱性が見つかりました。これにより、リモートの攻撃者が、任意の Web スクリプトまたは HTML をホスト名パラメータを介して注入できることがあります。(CVE-2008-1947)

- RequestDispatcher とサーブレットまたは JSP を組み合わせて使用するときのトラバーサル脆弱性が見つかりました。これにより、リモートの攻撃者が、特別に作り上げられたリクエストパラメータを利用して、保護されている Web リソースにアクセスできることがあります。(CVE-2008-2370)

Nessus では、この欠陥を実際にはテストしていませんが、その代わりに Tomcat のバナーのバージョンまたはエラー ページに依存しているため、誤検出の可能性があることに、注意してください。

ソリューション

Apache Tomcat をバージョン 6.0.18 または以降に更新してください。

関連情報

http://tomcat.apache.org/security-6.html#Fixed_in_Apache_Tomcat_6.0.18

プラグインの詳細

深刻度: Medium

ID: 47578

ファイル名: tomcat_6_0_18.nasl

バージョン: 1.24

タイプ: combined

エージェント: windows, macosx, unix

ファミリー: Web Servers

公開日: 2010/7/1

更新日: 2020/3/11

依存関係: apache_tomcat_nix_installed.nbin, tomcat_win_installed.nbin, tomcat_error_version.nasl

リスク情報

CVSS スコアのソース: CVE-2008-1232

VPR

リスクファクター: Medium

スコア: 4.2

CVSS v2

リスクファクター: Medium

Base Score: 5

Temporal Score: 3.9

ベクトル: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N

現状ベクトル: CVSS2#E:POC/RL:OF/RC:C

CVSS v3

リスクファクター: Medium

Base Score: 5.3

Temporal Score: 4.8

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

現状ベクトル: CVSS:3.0/E:P/RL:O/RC:C

脆弱性情報

CPE: cpe:2.3:a:apache:tomcat:*:*:*:*:*:*:*:*

必要な KB アイテム: installed_sw/Apache Tomcat

エクスプロイトが利用可能: true

エクスプロイトの容易さ: Exploits are available

パッチ公開日: 2008/7/31

脆弱性公開日: 2008/6/2

参照情報

CVE: CVE-2008-1232, CVE-2008-2370, CVE-2008-1947

BID: 30496, 30494

CWE: 79, 22

Secunia: 31379, 30500