CUPS < 1.4.4 複数の脆弱性

high Nessus プラグイン ID 47683

概要

リモートプリンターサービスは複数の脆弱性の影響を受けます。

説明

バナーによると、リモートホストにインストールされている CUPS のバージョンは 1.4.4 以前です。当該のバージョンはいくつかの脆弱性の影響を受けます。

- STR #3200/CVE-2009-3553 のパッチが完全ではありませんでした。リモートクライアントが、CUPS サーバーにすでに解放済みのリソースを参照させることで、サービス拒否を引き起こす可能性があります。(STR #3490)(CVE-2010-0302)

- CUPS デーモンが、悪意のある IFRAME 攻撃などの特定のクロスサイトリクエスト偽造(CSRF)攻撃に対して脆弱である可能性があります。(STR #3498)(CVE-2010-0540)

- 権限のないプロセスが、CUPS サーバーに root ユーザーとして任意のファイルを上書きさせることができる可能性があります。
(STR #3510)(CVE-2010-2431)

- 「textops」フィルターがメモリ割り当ての結果を検証しないため、CUPS デーモンは、ヒープ破損攻撃に対して脆弱です。これにより、任意のコードが実行される可能性があります。(STR #3516)(CVE-2010-0542)

- CUPS デーモンは、HAVE_GSSAPI なしでコンパイルされた場合、DoS 攻撃(サービス拒否攻撃)に対して脆弱です。(STR #3518)(CVE-2010-2432)

- 攻撃者が、特別に細工された URL によって初期化されていないメモリの一部を閲覧できるため、CUPS デーモンは、情報漏洩攻撃に対して脆弱です。
(STR #3577)(CVE-2010-1748)

ソリューション

CUPS バージョン 1.4.4 以降にアップグレードしてください。

関連情報

http://www.cups.org/str.php?L3490

http://www.cups.org/str.php?L3498

http://www.cups.org/str.php?L3510

http://www.cups.org/str.php?L3516

http://www.cups.org/str.php?L3518

http://www.cups.org/str.php?L3577

http://www.cups.org/articles.php?L596

プラグインの詳細

深刻度: High

ID: 47683

ファイル名: cups_1_4_4.nasl

バージョン: 1.12

タイプ: remote

ファミリー: Misc.

公開日: 2010/7/8

更新日: 2018/7/6

構成: パラノイドモードの有効化

リスク情報

VPR

リスクファクター: Medium

スコア: 5.9

CVSS v2

リスクファクター: High

Base Score: 7.5

Temporal Score: 5.9

ベクトル: AV:N/AC:L/Au:N/C:P/I:P/A:P

現状ベクトル: E:POC/RL:OF/RC:C

脆弱性情報

CPE: cpe:/a:apple:cups

必要な KB アイテム: www/cups, Settings/ParanoidReport

エクスプロイトが利用可能: true

エクスプロイトの容易さ: Exploits are available

パッチ公開日: 2010/6/17

脆弱性公開日: 2010/2/3

参照情報

CVE: CVE-2010-0302, CVE-2010-0540, CVE-2010-0542, CVE-2010-1748, CVE-2010-2431, CVE-2010-2432

BID: 38510, 40889, 40897, 40943, 41126, 41131

Secunia: 40165

CWE: 399