Mandriva Linux セキュリティアドバイザリ:kdelibs4(MDVSA-2010:027)

high Nessus プラグイン ID 48170

言語:

New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモート Mandriva Linux ホストには、1 つ以上のセキュリティ更新がありません。

説明

kdelibs4 で複数の脆弱性が見つかり、修正されました。

kdelibs 3.5.4、4.2.4、4.3 での KDE KSSL は、X.509 証明書の Subject Alternative Name フィールドで、ドメイン名にある「�」(NUL)文字を適切に処理していません。これにより、中間者攻撃の攻撃者は、正当な証明機関が発行した細工された証明書を通じて、任意の SSL サーバーを偽装することができます。これは、CVE-2009-2408 に関連する問題です(CVE-2009-2702)。

4.0 より前の Apple Safari、iPhone OS 1.0 ~ 2.2.1、および iPod touch 1.1 ~ 2.2.1 用の iPhone OS の WebKit の JavaScript ガベージコレクターは、割り当ての失敗を適切に処理しないため、リモートの攻撃者は、NULL ポインターのオフセットへの書き込みアクセスを発生させる、細工された HTML ドキュメントを使用して、任意のコードの実行、あるいはサービス拒否(メモリ破損およびアプリケーションクラッシュ)を引き起こす可能性があります。
(CVE-2009-1687)。

4.0.2 より前の Apple Safari、KDE の kdelibs の KHTML、および QtWebKit(別名 Qt ツールキット)などの製品の WebKit は、数値文字参照を適切に処理しないため、リモートの攻撃者は、細工された HTML ドキュメントを介して任意のコードの実行、あるいはサービス拒否(メモリ破損およびアプリケーションクラッシュ)を引き起こす可能性があります(CVE-2009-1725)。

4.0 より前の Apple Safari、iPhone OS 1.0 ~ 2.2.1、iPod touch 1.1 ~ 2.2.1 用の iPhone OS、および Google Chrome 1.0.154.53 などの製品で使用されている WebKit の use-after-free の脆弱性により、リモートの攻撃者が、HTML エラーの発生時に子要素が解放され、その後アクセスされることを引き起こす HTML タグの詳細不明のプロパティを設定することで、任意のコードを実行したり、サービス拒否(メモリ破損およびアプリケーションクラッシュ)を引き起こすことが可能です。これは、特定の DOM イベントハンドラーの再帰に関連しています。(CVE-2009-1690)。

4.0 より前の Apple Safari、iPhone OS 1.0 ~ 2.2.1、および iPod touch 1.1 ~ 2.2.1 用の iPhone OS の WebKit は、大きな数値引数を使用する Cascading Style Sheet(CSS)属性関数呼び出しを処理する際、ポインターを初期化しません。これにより、リモートの攻撃者は、細工された HTML ドキュメントを介して、任意のコードの実行またはサービス拒否(メモリ破損およびアプリケーションクラッシュ)を引き起こす可能性があります(CVE-2009-1698)。

KDE Konqueror によって、リモートの攻撃者が、Select オブジェクトの長さプロパティに大きな整数値を使用してサービス拒否(メモリ消費)を発生させることができます。これは CVE-2009-1692(CVE-2009-2537)に関連する問題です。

FreeBSD 6.4 および 7.2、NetBSD 5.0、OpenBSD 4.5 の libc の gdtoa/misc.c における gdtoa(別名 new dtoa)の実装によって、コンテキスト依存の攻撃者がサービス拒否(アプリケーションのクラッシュ)を引き起こしたり、printf 関数のフォーマット引数の大きな精度値を介して配列のオーバーランに関連するその他の詳細不明の影響を与えたりすることがあります。(CVE-2009-0689)。

10.4.11 および 10.5.7 より前の 10.5 の Apple Mac OS X および Windows の 3.2.3 および 4 Public Beta より前の Safari で使用されている WebKit により、リモートの攻撃者が、メモリ破損を発生させる細工された SVGList オブジェクトを通じて、任意のコードを実行することが可能です(CVE-2009-0945)。

更新パッケージには、これらの問題を修正するため、パッチが適用されています。

ソリューション

影響を受けるパッケージを更新してください。

プラグインの詳細

深刻度: High

ID: 48170

ファイル名: mandriva_MDVSA-2010-027.nasl

バージョン: 1.21

タイプ: local

公開日: 2010/7/30

更新日: 2021/1/6

依存関係: ssh_get_info.nasl

リスク情報

VPR

リスクファクター: Medium

スコア: 6.6

CVSS v2

リスクファクター: High

Base Score: 9.3

Temporal Score: 7.3

ベクトル: AV:N/AC:M/Au:N/C:C/I:C/A:C

現状ベクトル: E:POC/RL:OF/RC:C

脆弱性情報

CPE: p-cpe:/a:mandriva:linux:kdelibs4-core, p-cpe:/a:mandriva:linux:kdelibs4-devel, p-cpe:/a:mandriva:linux:lib64kde3support4, p-cpe:/a:mandriva:linux:lib64kdecore5, p-cpe:/a:mandriva:linux:lib64kdefakes5, p-cpe:/a:mandriva:linux:lib64kdesu5, p-cpe:/a:mandriva:linux:lib64kdeui5, p-cpe:/a:mandriva:linux:lib64kdnssd4, p-cpe:/a:mandriva:linux:lib64kfile4, p-cpe:/a:mandriva:linux:lib64khtml5, p-cpe:/a:mandriva:linux:lib64kimproxy4, p-cpe:/a:mandriva:linux:lib64kio5, p-cpe:/a:mandriva:linux:lib64kjs4, p-cpe:/a:mandriva:linux:lib64kjsapi4, p-cpe:/a:mandriva:linux:lib64kjsembed4, p-cpe:/a:mandriva:linux:lib64kmediaplayer4, p-cpe:/a:mandriva:linux:lib64knewstuff2_4, p-cpe:/a:mandriva:linux:lib64knotifyconfig4, p-cpe:/a:mandriva:linux:lib64kntlm4, p-cpe:/a:mandriva:linux:lib64kparts4, p-cpe:/a:mandriva:linux:lib64kpty4, p-cpe:/a:mandriva:linux:lib64krosscore4, p-cpe:/a:mandriva:linux:lib64krossui4, p-cpe:/a:mandriva:linux:lib64ktexteditor4, p-cpe:/a:mandriva:linux:lib64kunittest4, p-cpe:/a:mandriva:linux:lib64kutils4, p-cpe:/a:mandriva:linux:lib64nepomuk4, p-cpe:/a:mandriva:linux:lib64plasma3, p-cpe:/a:mandriva:linux:lib64solid4, p-cpe:/a:mandriva:linux:lib64threadweaver4, p-cpe:/a:mandriva:linux:libkde3support4, p-cpe:/a:mandriva:linux:libkdecore5, p-cpe:/a:mandriva:linux:libkdefakes5, p-cpe:/a:mandriva:linux:libkdesu5, p-cpe:/a:mandriva:linux:libkdeui5, p-cpe:/a:mandriva:linux:libkdnssd4, p-cpe:/a:mandriva:linux:libkfile4, p-cpe:/a:mandriva:linux:libkhtml5, p-cpe:/a:mandriva:linux:libkimproxy4, p-cpe:/a:mandriva:linux:libkio5, p-cpe:/a:mandriva:linux:libkjs4, p-cpe:/a:mandriva:linux:libkjsapi4, p-cpe:/a:mandriva:linux:libkjsembed4, p-cpe:/a:mandriva:linux:libkmediaplayer4, p-cpe:/a:mandriva:linux:libknewstuff2_4, p-cpe:/a:mandriva:linux:libknotifyconfig4, p-cpe:/a:mandriva:linux:libkntlm4, p-cpe:/a:mandriva:linux:libkparts4, p-cpe:/a:mandriva:linux:libkpty4, p-cpe:/a:mandriva:linux:libkrosscore4, p-cpe:/a:mandriva:linux:libkrossui4, p-cpe:/a:mandriva:linux:libktexteditor4, p-cpe:/a:mandriva:linux:libkunittest4, p-cpe:/a:mandriva:linux:libkutils4, p-cpe:/a:mandriva:linux:libnepomuk4, p-cpe:/a:mandriva:linux:libplasma3, p-cpe:/a:mandriva:linux:libsolid4, p-cpe:/a:mandriva:linux:libthreadweaver4, cpe:/o:mandriva:linux:2009.1

必要な KB アイテム: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

エクスプロイトが利用可能: true

エクスプロイトの容易さ: Exploits are available

パッチ公開日: 2010/1/27

参照情報

CVE: CVE-2009-0689, CVE-2009-0945, CVE-2009-1687, CVE-2009-1690, CVE-2009-1698, CVE-2009-1725, CVE-2009-2537, CVE-2009-2702

BID: 34924, 35271, 35309, 35318, 35446, 35510, 36229

MDVSA: 2010:027

CWE: 94, 119, 189, 310, 399