Mandriva Linux セキュリティアドバイザリ:subversion(MDVSA-2010:199)

medium Nessus プラグイン ID 49967

言語:

New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモート Mandriva Linux ホストには、1 つ以上のセキュリティ更新がありません。

説明

subversion で脆弱性が発見され、修正されています:

Apache Subversion 1.5.8 より前の 1.5.x および 1.6.13 前の 1.6.x でディストリビュートされている Apache HTTP Server の mod_dav_svn モジュールの authz.c は、SVNPathAuthz short_circuit が有効化されている時、名前の指定されたリポジトリをルールの有効範囲として適切に処理しません。これにより、リモートの認証されたユーザーは、svn コマンドを使用して、意図されたアクセス制限をバイパスする可能性があります(CVE-2010-3315)。

2009.0 用のパッケージは、拡張メンテナンスプログラム以降に提供されます。詳細については、以下のサイトにアクセスしてください:
http://store.mandriva.com/product_info.php?cPath=149&products_id=4 90

この問題を修正する更新済みパッケージが適用されています。

ソリューション

影響を受けるパッケージを更新してください。

プラグインの詳細

深刻度: Medium

ID: 49967

ファイル名: mandriva_MDVSA-2010-199.nasl

バージョン: 1.13

タイプ: local

公開日: 2010/10/14

更新日: 2021/1/6

依存関係: ssh_get_info.nasl

リスク情報

VPR

リスクファクター: Medium

スコア: 5.8

CVSS v2

リスクファクター: Medium

Base Score: 6

Temporal Score: 4.4

ベクトル: AV:N/AC:M/Au:S/C:P/I:P/A:P

現状ベクトル: E:U/RL:OF/RC:C

脆弱性情報

CPE: p-cpe:/a:mandriva:linux:apache-mod_dav_svn, p-cpe:/a:mandriva:linux:apache-mod_dontdothat, p-cpe:/a:mandriva:linux:lib64svn-gnome-keyring0, p-cpe:/a:mandriva:linux:lib64svn-kwallet0, p-cpe:/a:mandriva:linux:lib64svn0, p-cpe:/a:mandriva:linux:lib64svnjavahl0, p-cpe:/a:mandriva:linux:lib64svnjavahl1, p-cpe:/a:mandriva:linux:libsvn-gnome-keyring0, p-cpe:/a:mandriva:linux:libsvn-kwallet0, p-cpe:/a:mandriva:linux:libsvn0, p-cpe:/a:mandriva:linux:libsvnjavahl0, p-cpe:/a:mandriva:linux:libsvnjavahl1, p-cpe:/a:mandriva:linux:perl-SVN, p-cpe:/a:mandriva:linux:python-svn, p-cpe:/a:mandriva:linux:ruby-svn, p-cpe:/a:mandriva:linux:subversion, p-cpe:/a:mandriva:linux:subversion-devel, p-cpe:/a:mandriva:linux:subversion-doc, p-cpe:/a:mandriva:linux:subversion-server, p-cpe:/a:mandriva:linux:subversion-tools, p-cpe:/a:mandriva:linux:svn-javahl, cpe:/o:mandriva:linux:2009.0, cpe:/o:mandriva:linux:2009.1, cpe:/o:mandriva:linux:2010.0, cpe:/o:mandriva:linux:2010.1

必要な KB アイテム: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2010/10/12

参照情報

CVE: CVE-2010-3315

BID: 43678

MDVSA: 2010:199