OpenSSL < 0.9.8q / 1.0.0c の複数の脆弱性

high Nessus プラグイン ID 51058
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモート Web サーバーは、複数の脆弱性の影響を受けます。

説明

バナーによると、リモート Web サーバーで 0.9.8q または 1.0.0c.以前のバージョンの OpenSSL が実行されています。当該のバージョンは、以下の複数の脆弱性の影響を受ける可能性があります。

- 保存されたセッションキャッシュ暗号スイートを変更することで、暗号スイートがより脆弱なバージョンにダウングレードする可能性があります。

- J-PAKE 実装にエラーが存在しており、共有の秘密を知らない人物による検証が成功する可能性があります。

ソリューション

OpenSSL 0.9.8q / 1.0.0c または以降にアップグレードしてください。

関連情報

https://www.openssl.org/news/secadv/20101202.txt

http://seb.dbzteam.org/crypto/jpake-session-key-retrieval.pdf

プラグインの詳細

深刻度: High

ID: 51058

ファイル名: openssl_1_0_0c.nasl

バージョン: 1.12

タイプ: remote

ファミリー: Web Servers

公開日: 2010/12/7

更新日: 2018/7/16

依存関係: http_version.nasl

構成: パラノイドモードの有効化

リスク情報

VPR

リスクファクター: Medium

スコア: 5.8

CVSS v2

リスクファクター: High

Base Score: 7.5

Temporal Score: 5.5

ベクトル: AV:N/AC:L/Au:N/C:P/I:P/A:P

現状ベクトル: E:U/RL:OF/RC:C

脆弱性情報

CPE: cpe:/a:openssl:openssl

必要な KB アイテム: Settings/ParanoidReport

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2010/12/2

脆弱性公開日: 2010/12/2

参照情報

CVE: CVE-2010-4180, CVE-2010-4252

BID: 45163, 45164

Secunia: 42473