Mac OS X : Apple Safari < 5.0.5

high Nessus プラグイン ID 53410
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

The remote host contains a web browser that is affected by several vulnerabilities.

説明

The version of Apple Safari installed on the remote Mac OS X host is earlier than 5.0.5. As such, it is potentially affected by several issues :

- An integer overflow issue in the handling of nodesets could lead to a crash or arbitrary code execution.
(CVE-2011-1290)

- A use-after-free issue in the handling of text nodes could lead to a crash or arbitrary code execution.
(CVE-2011-1344)

ソリューション

Upgrade to Apple Safari 5.0.5 or later.

関連情報

http://support.apple.com/kb/HT4596

http://lists.apple.com/archives/security-announce/2011/Apr/msg00002.html

プラグインの詳細

深刻度: High

ID: 53410

ファイル名: macosx_Safari5_0_5.nasl

バージョン: 1.10

タイプ: local

エージェント: macosx

公開日: 2011/4/14

更新日: 2018/7/14

依存関係: macosx_Safari31.nasl

リスク情報

VPR

リスクファクター: Medium

スコア: 5.9

CVSS v2

リスクファクター: High

Base Score: 9.3

Temporal Score: 6.9

ベクトル: AV:N/AC:M/Au:N/C:C/I:C/A:C

現状ベクトル: E:U/RL:OF/RC:C

脆弱性情報

CPE: cpe:/a:apple:safari

必要な KB アイテム: Host/local_checks_enabled, Host/uname, Host/MacOSX/Version, MacOSX/Safari/Installed

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2011/4/14

脆弱性公開日: 2011/3/9

参照情報

CVE: CVE-2011-1290, CVE-2011-1344

BID: 46822, 46849