openSUSE セキュリティ更新:kde4-kdnssd(openSUSE-SU-2010:1077-1)

medium Nessus プラグイン ID 53664
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモート openSUSE ホストに、セキュリティ更新がありません。

説明

kdenetwork のこの更新は、いくつかのバグとセキュリティ関連の問題を修正します:

- CVE-2010-1000:CVSS v2 ベーススコア:4.3 (AV:N/AC:M/Au:N/C:N/I:P/A:N):CWE-22 メタリンクファイルの「file」要素の「name」属性が適切にサニタイズされません。これを悪用して任意のディレクトリへファイルがダウンロードされる可能性があります。

- CVE-2008-4776: CVSS v2 ベーススコア:4.3(AV:N/AC:M/Au:N/C:N/I:N/A:P):CWE-119 含まれている libgadu バージョンにより、リモートサーバーが、バッファオーバーリードを介してサービス拒否(クラッシュ)を引き起こす可能性があります。

セキュリティ以外の問題:

- bnc#653852:kopete:ICQ ログインが破損し、ログインサーバーが変更されました

- bnc#516347:kopete は、yahoo に接続できません

ソリューション

影響を受ける kde4-kdnssd パッケージを更新します。

関連情報

https://bugzilla.novell.com/show_bug.cgi?id=516347

https://bugzilla.novell.com/show_bug.cgi?id=525528

https://bugzilla.novell.com/show_bug.cgi?id=604709

https://bugzilla.novell.com/show_bug.cgi?id=653852

https://lists.opensuse.org/opensuse-updates/2010-12/msg00043.html

プラグインの詳細

深刻度: Medium

ID: 53664

ファイル名: suse_11_1_kde4-kdnssd-101119.nasl

バージョン: 1.7

タイプ: local

エージェント: unix

公開日: 2011/5/5

更新日: 2021/1/14

依存関係: ssh_get_info.nasl

リスク情報

VPR

リスクファクター: Low

スコア: 3.7

CVSS v2

リスクファクター: Medium

Base Score: 5.8

ベクトル: AV:N/AC:M/Au:N/C:N/I:P/A:P

脆弱性情報

CPE: p-cpe:/a:novell:opensuse:kde4-kdnssd, p-cpe:/a:novell:opensuse:kde4-kget, p-cpe:/a:novell:opensuse:kde4-knewsticker, p-cpe:/a:novell:opensuse:kde4-kopete, p-cpe:/a:novell:opensuse:kde4-kopete-devel, p-cpe:/a:novell:opensuse:kde4-kppp, p-cpe:/a:novell:opensuse:kde4-krdc, p-cpe:/a:novell:opensuse:kde4-krfb, p-cpe:/a:novell:opensuse:kdenetwork4, p-cpe:/a:novell:opensuse:kdenetwork4-filesharing, cpe:/o:novell:opensuse:11.1

必要な KB アイテム: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

パッチ公開日: 2010/11/19

参照情報

CVE: CVE-2008-4776, CVE-2010-1000

CWE: 119