Apache 2.2.x < 2.2.18 APR apr_fnmatch DoS

medium Nessus プラグイン ID 53896
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

The remote web server may be affected by a denial of service vulnerability.

説明

According to its banner, the version of Apache 2.2.x running on the remote host is prior to 2.2.18. It is, therefore, affected by a denial of service vulnerability due to an error in the apr_fnmatch() function of the bundled APR library.

If mod_autoindex is enabled and has indexed a directory containing files whose filenames are long, an attacker can cause high CPU usage with a specially crafted request.

Note that the remote web server may not actually be affected by this vulnerability. Nessus did not try to determine whether the affected module is in use or to check for the issue itself.

ソリューション

Upgrade to Apache version 2.2.18 or later. Alternatively, ensure that the 'IndexOptions' configuration option is set to 'IgnoreClient'.

関連情報

https://archive.apache.org/dist/httpd/CHANGES_2.2.18

http://httpd.apache.org/security/vulnerabilities_22.html#2.2.18

http://securityreason.com/achievement_securityalert/98

プラグインの詳細

深刻度: Medium

ID: 53896

ファイル名: apache_2_2_18.nasl

バージョン: 1.20

タイプ: remote

ファミリー: Web Servers

公開日: 2011/5/13

更新日: 2018/6/29

依存関係: apache_http_version.nasl

リスク情報

VPR

リスクファクター: Low

スコア: 2.2

CVSS v2

リスクファクター: Medium

Base Score: 4.3

Temporal Score: 3.4

ベクトル: CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P

現状ベクトル: CVSS2#E:POC/RL:OF/RC:C

CVSS v3

リスクファクター: Medium

Base Score: 5.3

Temporal Score: 4.8

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

現状ベクトル: CVSS:3.0/E:P/RL:O/RC:C

脆弱性情報

CPE: cpe:2.3:a:apache:http_server:*:*:*:*:*:*:*:*

必要な KB アイテム: installed_sw/Apache

エクスプロイトが利用可能: true

エクスプロイトの容易さ: Exploits are available

パッチ公開日: 2011/5/12

脆弱性公開日: 2011/5/10

参照情報

CVE: CVE-2011-0419

BID: 47820

Secunia: 44574