Mandriva Linux Security Advisory : libzip (MDVSA-2011:099)

medium Nessus プラグイン ID 54638
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモート Mandriva Linux ホストには、1 つ以上のセキュリティ更新がありません。

説明

libzip で脆弱性が確認され、修正されました:

5.3.6より前のPHPにおけるZip拡張のzip_name_locate.cの_zip_name_locate関数は、ZIPARCHIVE: : FL_UNCHANGED引数を適切に処理しません。これにより、コンテキスト依存の攻撃者が、(1)locateNameまたは(2)statName演算で処理された空のZIPアーカイブを介してサービス拒否(アプリケーションのクラッシュ)を引き起こす可能性があります。(CVE-2011-0421)。

2009.0 用のパッケージは、拡張メンテナンスプログラム以降に提供されます。詳細については、以下のサイトにアクセスしてください:
http://store.mandriva.com/product_info.php?cPath=149 products_id=490

この問題を修正する更新済みパッケージが適用されています。

ソリューション

影響を受けるパッケージを更新してください。

プラグインの詳細

深刻度: Medium

ID: 54638

ファイル名: mandriva_MDVSA-2011-099.nasl

バージョン: 1.11

タイプ: local

公開日: 2011/5/25

更新日: 2021/1/6

依存関係: ssh_get_info.nasl

リスク情報

VPR

リスクファクター: Medium

スコア: 4.4

CVSS v2

リスクファクター: Medium

Base Score: 4.3

Temporal Score: 3.4

ベクトル: CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P

現状ベクトル: CVSS2#E:POC/RL:OF/RC:C

脆弱性情報

CPE: cpe:2.3:o:mandriva:linux:2009.0:*:*:*:*:*:*:*, cpe:2.3:o:mandriva:linux:2010.1:*:*:*:*:*:*:*, p-cpe:2.3:a:mandriva:linux:lib64zip-devel:*:*:*:*:*:*:*, p-cpe:2.3:a:mandriva:linux:libzip:*:*:*:*:*:*:*, p-cpe:2.3:a:mandriva:linux:libzip-devel:*:*:*:*:*:*:*, p-cpe:2.3:a:mandriva:linux:lib64zip1:*:*:*:*:*:*:*, p-cpe:2.3:a:mandriva:linux:lib64zip1-devel:*:*:*:*:*:*:*, p-cpe:2.3:a:mandriva:linux:libzip1:*:*:*:*:*:*:*, p-cpe:2.3:a:mandriva:linux:libzip1-devel:*:*:*:*:*:*:*

必要な KB アイテム: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

エクスプロイトが利用可能: true

エクスプロイトの容易さ: Exploits are available

パッチ公開日: 2011/5/24

参照情報

CVE: CVE-2011-0421

BID: 46354

MDVSA: 2011:099