Firefox 3.6 < 3.6.18 の複数の脆弱性(Mac OS X)

high Nessus プラグイン ID 55418
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモートのMac OS Xホストに、複数の脆弱性の影響を受けるWebブラウザーが含まれています。

説明

Firefox のインストールバージョンは 3.6.x で、3.6.18 より前です。上記のバージョンは以下のセキュリティ問題の影響を受ける可能性があります。

- 複数のメモリの安全性に関する問題により、アプリケーションのクラッシュや、リモートコードの実行が引き起こされる可能性があります。
(CVE-2011-2374、CVE-2011-2376、CVE-2011-2364、CVE-2011-2365)

- スクリプトを無効化した状態で XUL ドキュメントを表示する際の use-after-free の問題により、コードの実行が引き起こされる可能性があります。
(CVE-2011-2373)

- multipart / x-mixed-replace イメージによるメモリ破損の問題があるため、メモリ破損が発生する可能性があります。
(CVE-2011-2377)

- JavaScript配列オブジェクトの長さが非常に大きな値に設定されると、reduceRightメソッドが呼び出される際に発生する配列要素の繰り返しにより、無効なインデックス値が使用されることが原因のコードの実行が発生することがあります。(CVE-2011-2371)

- 複数のダングリングポインターの脆弱性により、コードの実行が引き起こされる可能性があります。(CVE-2011-0083、CVE-2011-2363、CVE-2011-0085)

- クッキーが処理される方法にエラーがあるため、情報漏洩が発生することがあります。(CVE-2011-2362)

ソリューション

Firefox 3.6.18以降にアップグレードしてください。

関連情報

http://www.nessus.org/u?5694f54a

https://www.mozilla.org/en-US/security/advisories/mfsa2011-19/

https://www.mozilla.org/en-US/security/advisories/mfsa2011-20/

https://www.mozilla.org/en-US/security/advisories/mfsa2011-21/

https://www.mozilla.org/en-US/security/advisories/mfsa2011-22/

https://www.mozilla.org/en-US/security/advisories/mfsa2011-23/

https://www.mozilla.org/en-US/security/advisories/mfsa2011-24/

http://www.zerodayinitiative.com/advisories/ZDI-11-223/

http://www.zerodayinitiative.com/advisories/ZDI-11-224/

http://www.zerodayinitiative.com/advisories/ZDI-11-225/

プラグインの詳細

深刻度: High

ID: 55418

ファイル名: macosx_firefox_3_6_18.nasl

バージョン: 1.12

タイプ: local

エージェント: macosx

公開日: 2011/6/24

更新日: 2018/7/14

依存関係: macosx_firefox_installed.nasl

リスク情報

VPR

リスクファクター: Critical

スコア: 9.7

CVSS v2

リスクファクター: High

Base Score: 9.3

Temporal Score: 8.1

ベクトル: AV:N/AC:M/Au:N/C:C/I:C/A:C

現状ベクトル: E:H/RL:OF/RC:C

脆弱性情報

CPE: cpe:/a:mozilla:firefox

必要な KB アイテム: MacOSX/Firefox/Installed

エクスプロイトが利用可能: true

エクスプロイトの容易さ: Exploits are available

パッチ公開日: 2011/6/21

脆弱性公開日: 2011/6/21

エクスプロイト可能

CANVAS (CANVAS)

Metasploit (Mozilla Firefox Array.reduceRight() Integer Overflow)

参照情報

CVE: CVE-2011-0083, CVE-2011-0085, CVE-2011-2362, CVE-2011-2363, CVE-2011-2364, CVE-2011-2365, CVE-2011-2371, CVE-2011-2373, CVE-2011-2374, CVE-2011-2376, CVE-2011-2377

BID: 48357, 48358, 48360, 48361, 48365, 48366, 48367, 48368, 48369, 48372, 48373, 48376

Secunia: 44982