Novell File Reporter Engine の RECORD 要素のタグ解析のオーバーフロー(uncredentialed check)

high Nessus プラグイン ID 55544

概要

リモートホストは、リモートバッファオーバーフロー攻撃に脆弱なサービスを実行しています。

説明

リモートホストで実行中の Novell File Reporter(NFR)Engine のバージョンは、リモートバッファオーバーフロー攻撃に脆弱です。特に、「<RECORD>」要素内でタグを解析する場合、アプリケーションは memcpy の呼び出しにユーザー指定文字列を使用する前に、同文字列のサイズチェックに失敗します。

サービスにアクセスしている、認証されていないリモートの攻撃者は、この脆弱性を利用して、プロセススレッドのスタックを破損することができるため、権限があるアカウントのコンテキストで、任意のコードの実行を引き起こす可能性があります。

ソリューション

Novell のアドバイザリで言及されているセキュリティのパッチを適用してください。

関連情報

https://www.zerodayinitiative.com/advisories/ZDI-11-227/

https://www.securityfocus.com/archive/1/518632/30/0/threaded

http://download.novell.com/Download?buildid=leLxi7tQACs~

プラグインの詳細

深刻度: High

ID: 55544

ファイル名: novell_file_reporter_engine_stack_overflow.nbin

バージョン: 1.67

タイプ: remote

ファミリー: Gain a shell remotely

公開日: 2011/7/8

更新日: 2022/2/14

リスク情報

VPR

リスクファクター: High

スコア: 7.4

CVSS v2

リスクファクター: High

Base Score: 9.7

Temporal Score: 8

ベクトル: AV:N/AC:L/Au:N/C:C/I:C/A:P

現状ベクトル: E:F/RL:OF/RC:C

脆弱性情報

必要な KB アイテム: Services/NFR-engine

除外される KB アイテム: Settings/disable_cgi_scanning

エクスプロイトが利用可能: true

エクスプロイトの容易さ: Exploits are available

パッチ公開日: 2011/6/27

脆弱性公開日: 2011/6/27

エクスプロイト可能

CANVAS (White_Phosphorus)

Core Impact

参照情報

CVE: CVE-2011-2220

BID: 48470

Secunia: 45065