PHP 5.3 < 5.3.7 の複数の脆弱性

critical Nessus プラグイン ID 55925

概要

リモート Web サーバーが使用するバージョンの PHP は、複数の脆弱性の影響を受けます。

説明

バナーによると、リモートホストにインストールされている PHP 5.3.x のバージョンは、5.3.7 より前です。新しいバージョンでは、以下の問題が解決されます。

- socket_connect() でのスタックベースのバッファオーバーフロー。
(CVE-2011-1938)

- substr_replace() での解放済みメモリ使用の脆弱性。
(CVE-2011-1148)

- ZipArchive::addGlob() でのコード実行脆弱性。
(CVE-2011-1657)

- crypt_blowfish が 1.2 に更新されました。(CVE-2011-2483)

- 複数の NULL ポインタデリファレンス。(CVE-2011-3182)

- error_log() での未特定のクラッシュ。(CVE-2011-3267)

- crypt() でのバッファオーバーフロー。(CVE-2011-3268)

ソリューション

PHP 5.3.7 または以降にアップグレードしてください。

関連情報

http://securityreason.com/achievement_securityalert/101

http://securityreason.com/exploitalert/10738

https://bugs.php.net/bug.php?id=54238

https://bugs.php.net/bug.php?id=54681

https://bugs.php.net/bug.php?id=54939

http://www.php.net/releases/5_3_7.php

プラグインの詳細

深刻度: Critical

ID: 55925

ファイル名: php_5_3_7.nasl

バージョン: 1.21

タイプ: remote

ファミリー: CGI abuses

公開日: 2011/8/22

更新日: 2022/4/11

構成: 徹底的なチェックを有効にする

リスク情報

VPR

リスクファクター: Medium

スコア: 6.1

CVSS v2

リスクファクター: Critical

Base Score: 10

Temporal Score: 7.8

ベクトル: AV:N/AC:L/Au:N/C:C/I:C/A:C

現状ベクトル: E:POC/RL:OF/RC:C

CVSS スコアのソース: CVE-2011-3268

脆弱性情報

CPE: cpe:/a:php:php

必要な KB アイテム: www/PHP

エクスプロイトの容易さ: No exploit is required

パッチ公開日: 2011/8/18

脆弱性公開日: 2011/3/13

参照情報

CVE: CVE-2011-1148, CVE-2011-1657, CVE-2011-1938, CVE-2011-2202, CVE-2011-2483, CVE-2011-3182, CVE-2011-3267, CVE-2011-3268

BID: 46843, 47950, 48259, 49241, 49249, 49252

EDB-ID: 17318, 17486