Apache Tomcat 6.0.x < 6.0.33 の複数の脆弱性

medium Nessus プラグイン ID 56008

概要

リモート Web サーバーは、複数の脆弱性の影響を受けることがあります。

説明

自己報告されたバージョン番号によると、リモートホストでリッスンしている Apache Tomcat 6.0.x のインスタンスは、6.0.33 より前のバージョンです。そのため、複数の脆弱性の影響を受けることがあります。

- HTTP Digest 認証実装に複数の弱点が見つかりました。問題は以下のとおりです。
リプレイ攻撃が可能、
サーバーのノンスがチェックされない、クライアントのノンス回数がチェックされない、
「保護品質」(qop)値がチェックされない、
レルム値がチェックされず、サーバーの秘密がハードコードされた既知の文字列になっている。これらの問題の影響で、Digest 認証の強度が Basic 認証以下になっています。(CVE-2011-1184、CVE-2011-5062、
CVE-2011-5063、CVE-2011-5064)

- MemoryUserDatabase に関連したエラー処理の問題があります。これにより、ログファイルでユーザーパスワードを漏洩できます。(CVE-2011-2204)

- 入力検証エラーがあります。これにより、APR または NIO コネクターが有効な場合、ローカル攻撃者は、セキュリティをバイパスすることや、サービス拒否攻撃を実行することができます。(CVE-2011-2526)

- Apache Tomcat が依存している「jsvc」と呼ばれるコンポーネントに、エラーが含まれています。このエラーでは、開始後の機能がドロップされないため、スーパーユーザーが所有する機密ファイルにアクセスできることがあります。この脆弱性の影響を受けるのは Linux オペレーティングシステムだけであり、右記が true の場合のみであることに、注意してください: jsvc が libpcap でコンパイルされており、「-user」パラメータが使用されている。(CVE-2011-2729)

Nessus では、実際にはこれらの欠陥をテストせず、その代わりに Tomcat のバナーのバージョンまたはエラーページに依存していることに、注意してください。

ソリューション

Apache Tomcat をバージョン 6.0.33 または以降に更新してください。

関連情報

http://tomcat.apache.org/security-6.html#Fixed_in_Apache_Tomcat_6.0.33

http://www.nessus.org/u?b56cc2cd

プラグインの詳細

深刻度: Medium

ID: 56008

ファイル名: tomcat_6_0_33.nasl

バージョン: 1.21

タイプ: combined

エージェント: windows, macosx, unix

ファミリー: Web Servers

公開日: 2011/8/30

更新日: 2022/4/11

構成: 徹底的なチェックを有効にする

サポートされているセンサー: Nessus Agent

リスク情報

VPR

リスクファクター: Medium

スコア: 5.8

CVSS v2

リスクファクター: Medium

Base Score: 5

Temporal Score: 3.7

ベクトル: AV:N/AC:L/Au:N/C:P/I:N/A:N

現状ベクトル: E:U/RL:OF/RC:C

CVSS スコアのソース: CVE-2011-1184

CVSS v3

リスクファクター: Medium

Base Score: 5.3

Temporal Score: 4.6

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: cpe:/a:apache:tomcat

必要な KB アイテム: installed_sw/Apache Tomcat

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2011/8/18

脆弱性公開日: 2011/6/27

参照情報

CVE: CVE-2011-1184, CVE-2011-2204, CVE-2011-2526, CVE-2011-2729, CVE-2011-5062, CVE-2011-5063, CVE-2011-5064

BID: 48456, 48667, 49143, 49762