SeaMonkey < 2.4.0 の複数の脆弱性

high Nessus プラグイン ID 56337
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモートのWindowsホストに含まれるWebブラウザは複数の脆弱性の影響を受けます。

説明

SeaMonkey のインストールバージョンは、 2.4.0 より前です。上記のバージョンは以下のセキュリティ問題の影響を受ける可能性があります。

- 悪意のあるゲームなどを介して攻撃者がユーザーを騙して「Enter」キーを押させると、悪意のあるアプリケーションまたは拡張機能がダウンロードされ、実行される可能性があります(CVE-2011-2372、CVE-2011-3001)

- 悪用されてメモリ破損の可能性がある、詳細不明のエラーが存在します。現時点で追加情報はありません。(CVE-2011-2995、CVE-2011-2997)

-「Location」ヘッダーを処理する時に欠陥が存在します。
これによって、脆弱性がある Web サーバーにアクセスする時に、応答分割攻撃が発生する可能性があります。同じ修正が「Content-Length」および「Content-Disposition」ヘッダーに適用されています。(CVE-2011-3000)

- 「WebGL」の ANGLE ライブラリ内にエラーが存在します。これは「GrowAtomTable()」関数からの戻り値を適切にチェックしません。この脆弱性を悪用して一連のリクエストを送信することにより、バッファオーバーフローが発生する可能性があります。さらに、詳細不明のエラーが WebGL 内部に存在し、これが悪用されるとメモリが破損する可能性があります。(CVE-2011-3002、CVE-2011-3003)

- 'JSSubScriptLoader 内に、「XPCNativeWrappers」を不適切にアンラップするエラーがあります。ユーザーを騙して悪意のあるプラグインをインストールさせることにより、攻撃者がこの問題を悪用して任意のコードコードを実行する可能性があります。
(CVE-2011-3004)

- OGG ヘッダーの解析時に、use-after-free エラーが存在します。
(CVE-2011-3005)

- YARR正規表現ライブラリ内部に詳細不明のエラーがあり、これが悪用されてメモリ破損が発生する可能性があります。(CVE-2011-3232)

ソリューション

SeaMonkey 2.4.0 以降にアップグレードしてください。

関連情報

https://www.mozilla.org/en-US/security/advisories/mfsa2011-36/

https://www.mozilla.org/en-US/security/advisories/mfsa2011-39/

https://www.mozilla.org/en-US/security/advisories/mfsa2011-40/

https://www.mozilla.org/en-US/security/advisories/mfsa2011-41/

https://www.mozilla.org/en-US/security/advisories/mfsa2011-42/

https://www.mozilla.org/en-US/security/advisories/mfsa2011-43/

https://www.mozilla.org/en-US/security/advisories/mfsa2011-44/

https://www.mozilla.org/en-US/security/advisories/mfsa2011-45/

プラグインの詳細

深刻度: High

ID: 56337

ファイル名: seamonkey_24.nasl

バージョン: 1.9

タイプ: local

エージェント: windows

ファミリー: Windows

公開日: 2011/9/29

更新日: 2018/7/27

依存関係: mozilla_org_installed.nasl

リスク情報

VPR

リスクファクター: Medium

スコア: 5.9

CVSS v2

リスクファクター: High

Base Score: 9.3

Temporal Score: 6.9

ベクトル: AV:N/AC:M/Au:N/C:C/I:C/A:C

現状ベクトル: E:U/RL:OF/RC:C

脆弱性情報

CPE: cpe:/a:mozilla:seamonkey

必要な KB アイテム: SeaMonkey/Version

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2011/9/27

脆弱性公開日: 2011/9/27

参照情報

CVE: CVE-2011-2372, CVE-2011-2995, CVE-2011-2997, CVE-2011-3000, CVE-2011-3001, CVE-2011-3002, CVE-2011-3003, CVE-2011-3004, CVE-2011-3005, CVE-2011-3232

BID: 49800, 49808, 49811, 49813, 49837, 49847, 49849, 49850, 49852