RHEL 4 / 5 / 6:java-1.5.0-ibm(RHSA-2011: 1478)

critical Nessus プラグイン ID 56942
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモートのRed Hatホストに、1つ以上のセキュリティ更新プログラムがありません。

説明

複数のセキュリティ問題を修正する更新済みのjava-1.5.0-ibmパッケージがRed Hat Enterprise Linux 4 Extras、およびRed Hat Enterprise Linux 5および6 Supplementaryで現在利用可能です。

Red Hatセキュリティレスポンスチームは、この更新がセキュリティに及ぼす影響を重要度最高として評価しています。詳細な重要度の評価を提供するCommon Vulnerability Scoring System(CVSS)のベーススコアは、「参照」セクションのCVEリンクから脆弱性ごとに確認できます。

IBM 1.5.0 の Java リリースには、IBM Java 2 Runtime Environment および IBM Java 2 ソフトウェア開発キットが収納されています。

この更新は、IBM Java 2 Runtime Environment および IBM Java 2 ソフトウェア開発キットの複数の脆弱性を修正します。脆弱性の詳細な説明は、「参照」セクションにリストされているIBM「セキュリティアラート」ページからリンクされています。(CVE-2011-3545、CVE-2011-3547、CVE-2011-3548、CVE-2011-3549、CVE-2011-3552、CVE-2011-3554、CVE-2011-3556)

java-1.5.0-ibm の全ユーザーは、IBM 1.5.0 SR13 Java リリースが含まれるこれらの更新済みパッケージにアップグレードすることが推奨されます。更新を有効にするには、IBM Java のすべての実行中のインスタンスを再起動する必要があります。

ソリューション

影響を受けるパッケージを更新してください。

関連情報

https://access.redhat.com/security/cve/cve-2011-3545

https://access.redhat.com/security/cve/cve-2011-3547

https://access.redhat.com/security/cve/cve-2011-3548

https://access.redhat.com/security/cve/cve-2011-3549

https://access.redhat.com/security/cve/cve-2011-3552

https://access.redhat.com/security/cve/cve-2011-3554

https://access.redhat.com/security/cve/cve-2011-3556

https://developer.ibm.com/javasdk/support/security-vulnerabilities/

http://www.nessus.org/u?3fed43a3

https://access.redhat.com/errata/RHSA-2011:1478

プラグインの詳細

深刻度: Critical

ID: 56942

ファイル名: redhat-RHSA-2011-1478.nasl

バージョン: 1.22

タイプ: local

エージェント: unix

公開日: 2011/11/26

更新日: 2021/1/14

依存関係: ssh_get_info.nasl

リスク情報

VPR

リスクファクター: Critical

スコア: 9.3

CVSS v2

リスクファクター: Critical

Base Score: 10

Temporal Score: 8.3

ベクトル: AV:N/AC:L/Au:N/C:C/I:C/A:C

現状ベクトル: E:F/RL:OF/RC:C

脆弱性情報

CPE: p-cpe:/a:redhat:enterprise_linux:java-1.5.0-ibm, p-cpe:/a:redhat:enterprise_linux:java-1.5.0-ibm-accessibility, p-cpe:/a:redhat:enterprise_linux:java-1.5.0-ibm-demo, p-cpe:/a:redhat:enterprise_linux:java-1.5.0-ibm-devel, p-cpe:/a:redhat:enterprise_linux:java-1.5.0-ibm-javacomm, p-cpe:/a:redhat:enterprise_linux:java-1.5.0-ibm-jdbc, p-cpe:/a:redhat:enterprise_linux:java-1.5.0-ibm-plugin, p-cpe:/a:redhat:enterprise_linux:java-1.5.0-ibm-src, cpe:/o:redhat:enterprise_linux:4, cpe:/o:redhat:enterprise_linux:5, cpe:/o:redhat:enterprise_linux:6, cpe:/o:redhat:enterprise_linux:6.1

必要な KB アイテム: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list, Host/cpu

エクスプロイトが利用可能: true

エクスプロイトの容易さ: Exploits are available

パッチ公開日: 2011/11/24

脆弱性公開日: 2011/10/19

エクスプロイト可能

Metasploit (Java RMI Server Insecure Default Configuration Java Code Execution)

参照情報

CVE: CVE-2011-3545, CVE-2011-3547, CVE-2011-3548, CVE-2011-3549, CVE-2011-3552, CVE-2011-3554, CVE-2011-3556

BID: 50211, 50216, 50220, 50223, 50231, 50243, 50248

RHSA: 2011:1478