Ubuntu 10.04 LTS / 10.10:xulrunner-1.9.2 の脆弱性(USN-1401-1)

high Nessus プラグイン ID 58397

概要

リモート Ubuntu ホストにセキュリティ関連パッチがありません。

説明

DOMAttrModified イベントハンドラー中に SVG 要素が削除された場合に、有効範囲外のメモリアクセスになるという Mozilla SVG 実装に欠陥が見つかりました。ユーザーがだまされて特別に細工されたページを開くと、攻撃者はこれを悪用し、アプリケーションのクラッシュを介してサービス拒否を引き起こす可能性があります。(CVE-2011-3658)

Atte Kettunen 氏は、Gecko レンダリングエンジンが SVG アニメーションを処理する方法に use-after-free の脆弱性を発見しました。攻撃者はこれを悪用して、Xulrunner ベースのアプリケーションを起動しているユーザーの権限で任意のコードを実行する可能性があります。(CVE-2012-0457)

Atte Kettunen 氏は、Gecko レンダリングエンジンが SVG フィルターを処理する方法に領域外読み取りの脆弱性を発見しました。攻撃者は、これを悪用し、ページコンテンツにアクセス可能なユーザーのメモリからデータを作成する可能性があります。(CVE-2012-0456)

Soroush Dalili 氏は、Gecko レンダリングエンジンが JavaScript リンクをフレームにドロップすることに対して充分な保護がないことを発見しました。リモートの攻撃者が、クロスサイトスクリプティング(XSS)を通じて、これを悪用することにより、フレームのコンテンツを変更したり、機密データを盗み出したりする可能性があります。
(CVE-2012-0455)

Mariusz Mlynski 氏は、ホームボタンに JavaScript リンクを受け入れると、ブラウザのホームページが設定されてしまうことを発見しました。攻撃者が、この脆弱性を利用することにより、権限のある about:sessionrestore コンテキストでスクリプト URL を読み込む可能性があります。(CVE-2012-0458)

Bob Clary 氏、Vincenzo Iozzo 氏、および Willem Pinckaers 氏は、Firefox に影響を与えるメモリ安全性の問題を発見しました。ユーザーが騙されて、特別に細工されたページを開いた場合、攻撃者がこれを悪用して、アプリケーションのクラッシュを通じて、サービス拒否を引き起こすことや、 Firefox を起動しているユーザーの権限でコードを実行する可能性があります。(CVE-2012-0461、 CVE-2012-0464)。

ソリューション

影響を受ける xulrunner-1.9.2 パッケージを更新してください。

関連情報

https://usn.ubuntu.com/1401-1/

プラグインの詳細

深刻度: High

ID: 58397

ファイル名: ubuntu_USN-1401-1.nasl

バージョン: 1.18

タイプ: local

エージェント: unix

公開日: 2012/3/20

更新日: 2019/9/19

サポートされているセンサー: Frictionless Assessment Agent, Frictionless Assessment AWS, Frictionless Assessment Azure, Nessus Agent

リスク情報

VPR

リスクファクター: High

スコア: 8.5

CVSS v2

リスクファクター: High

Base Score: 9.3

Temporal Score: 8.1

ベクトル: AV:N/AC:M/Au:N/C:C/I:C/A:C

現状ベクトル: E:H/RL:OF/RC:C

脆弱性情報

CPE: p-cpe:/a:canonical:ubuntu_linux:xulrunner-1.9.2, cpe:/o:canonical:ubuntu_linux:10.04:-:lts, cpe:/o:canonical:ubuntu_linux:10.10

必要な KB アイテム: Host/cpu, Host/Ubuntu, Host/Ubuntu/release, Host/Debian/dpkg-l

エクスプロイトが利用可能: true

エクスプロイトの容易さ: Exploits are available

パッチ公開日: 2012/3/19

脆弱性公開日: 2011/12/20

エクスプロイト可能

CANVAS (CANVAS)

Metasploit (Firefox nsSVGValue Out-of-Bounds Access Vulnerability)

参照情報

CVE: CVE-2011-3658, CVE-2012-0455, CVE-2012-0456, CVE-2012-0457, CVE-2012-0458, CVE-2012-0461, CVE-2012-0464

BID: 51138, 52458, 52459, 52460, 52461, 52464, 52465

USN: 1401-1