MySQL 5.5 < 5.5.22 複数の脆弱性

high Nessus プラグイン ID 58661

概要

リモートデータベースサーバーは、複数の脆弱性の影響を受けます。

説明

リモートホストにインストールされている MySQL 5.5 のバージョンは、 5.5.22 より前です。したがって、次の脆弱性の影響を受けます:

- 任意のコードを実行可能にする付属の yaSSL コンポーネントに関連するエラーが存在します。
(CVE-2012-0882)

- 「Server Optimizer」、「Server DML」、「Partition」に関連するエラーや、InnoDB と「HANDLER READ NEXT」の組み合わせに関連するエラーが存在し、これによってサービス拒否攻撃が可能になります。(CVE-2012-1688、CVE-2012-1690、CVE-2012-1697、 CVE-2012-1703、CVE-2012-2102)

ソリューション

MySQL バージョン 5.5.22 以降にアップグレードしてください。

関連情報

http://dev.mysql.com/doc/refman/5.5/en/news-5-5-22.html

http://www.nessus.org/u?4225df87

https://www.openwall.com/lists/oss-security/2012/02/24/2

プラグインの詳細

深刻度: High

ID: 58661

ファイル名: mysql_5_5_22.nasl

バージョン: 1.15

タイプ: remote

ファミリー: Databases

公開日: 2012/4/11

更新日: 2018/11/15

構成: パラノイドモードの有効化

リスク情報

VPR

リスクファクター: Medium

スコア: 5.9

CVSS v2

リスクファクター: High

Base Score: 7.5

Temporal Score: 5.5

ベクトル: AV:N/AC:L/Au:N/C:P/I:P/A:P

現状ベクトル: E:U/RL:OF/RC:C

脆弱性情報

CPE: cpe:/a:mysql:mysql

必要な KB アイテム: Settings/ParanoidReport

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2012/3/21

脆弱性公開日: 2012/3/21

参照情報

CVE: CVE-2012-0882, CVE-2012-1688, CVE-2012-1690, CVE-2012-1697, CVE-2012-1703, CVE-2012-2102

BID: 51925, 52931, 53058, 53064, 53067, 53074