OpenSSL 1.0.0 < 1.0.0j の DTLS CBC でのサービス拒否

medium Nessus プラグイン ID 59077
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモートホストは、サービス拒否脆弱性の影響を受けることがあります。

説明

バナーによると、リモート Web サーバーで 1.0.0j より前のバージョンの OpenSSL 1.0.0 が実行されています。それ自体、報告されているところによれば、OpenSSL ライブラリ自体がサービス拒否脆弱性の影響を受けます。

ファイル「ssl/d1_enc.c」の関数「dtls1_enc」に、整数アンダーフローエラーがあります。CBC モードの場合、DTLS パケットに関連する DTLS レコード長の値および明示的な初期化ベクトル長の値が適切に処理されません。このため、メモリ破損およびアプリケーションのクラッシュが発生することがあります。

ソリューション

OpenSSL 1.0.0j または以降にアップグレードしてください。

関連情報

https://www.openssl.org/news/secadv/20120510.txt

https://www.openssl.org/news/changelog.html

http://cvs.openssl.org/chngview?cn=22538

https://bugzilla.redhat.com/show_bug.cgi?id=820686

プラグインの詳細

深刻度: Medium

ID: 59077

ファイル名: openssl_1_0_0j.nasl

バージョン: 1.8

タイプ: remote

ファミリー: Web Servers

公開日: 2012/5/11

更新日: 2018/11/15

依存関係: openssl_version.nasl

リスク情報

VPR

リスクファクター: Medium

スコア: 5.9

CVSS v2

リスクファクター: Medium

Base Score: 5

Temporal Score: 3.7

ベクトル: AV:N/AC:L/Au:N/C:N/I:N/A:P

現状ベクトル: E:U/RL:OF/RC:C

脆弱性情報

CPE: cpe:/a:openssl:openssl

必要な KB アイテム: openssl/port

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2012/5/10

脆弱性公開日: 2012/5/10

参照情報

CVE: CVE-2012-2333

BID: 53476