Mozilla Thunderbird 10.0.x < 10.0.5 の複数の脆弱性

high Nessus プラグイン ID 59410
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモートWindowsホストにあるメールクライアントが、いくつかの脆弱性の影響を受ける可能性があります。

説明

Thunderbird バージョン 10.0.x がインストールされている場合、次のセキュリティの問題による影響を受けます。

- 長さがゼロの項目を処理する際に、ASN.1デコーダーにエラーが存在するため、アプリケーションのクラッシュを引き起こす可能性があります。
(CVE-2012-0441)

複数のメモリの破損に関するエラーが存在します。(CVE-2012-1937、CVE-2012-1939)

2つのヒープベースのバッファオーバーフローと1つのヒープベースのuse-after-freeエラーがあり、悪用される可能性があります。
(CVE-2012-1940、CVE-2012-1941、CVE-2012-1947)

- 「Content Security Policy」(CSP)のインラインスクリプトブロッキング機能が、インラインイベントハンドラーを適切にブロックしません。このエラーにより、リモート攻撃者は、クロスサイトスクリプティング攻撃をより簡単に仕掛ける​恐れがあります。
(CVE-2012-1944)

- Webドキュメントにノードを挿入したり置き換えたりすることに関連する、use-after-freeエラーが存在します。(CVE-2012-1946)

ソリューション

Thunderbird 10.0.5 ESR 以降にアップグレードしてください。

関連情報

https://www.mozilla.org/en-US/security/advisories/mfsa2012-34/

https://www.mozilla.org/en-US/security/advisories/mfsa2012-36/

https://www.mozilla.org/en-US/security/advisories/mfsa2012-38/

https://www.mozilla.org/en-US/security/advisories/mfsa2012-39/

https://www.mozilla.org/en-US/security/advisories/mfsa2012-40/

プラグインの詳細

深刻度: High

ID: 59410

ファイル名: mozilla_thunderbird_1005.nasl

バージョン: 1.11

タイプ: local

エージェント: windows

ファミリー: Windows

公開日: 2012/6/7

更新日: 2018/7/16

依存関係: mozilla_org_installed.nasl

リスク情報

VPR

リスクファクター: Medium

スコア: 5.9

CVSS v2

リスクファクター: High

Base Score: 9.3

Temporal Score: 6.9

ベクトル: AV:N/AC:M/Au:N/C:C/I:C/A:C

現状ベクトル: E:U/RL:OF/RC:C

脆弱性情報

CPE: cpe:/a:mozilla:thunderbird

必要な KB アイテム: Mozilla/Thunderbird/Version

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2012/6/5

脆弱性公開日: 2012/6/5

参照情報

CVE: CVE-2012-0441, CVE-2012-1937, CVE-2012-1939, CVE-2012-1940, CVE-2012-1941, CVE-2012-1944, CVE-2012-1946, CVE-2012-1947

BID: 53791, 53792, 53793, 53794, 53797, 53798, 53800, 53801

CWE: 20, 74, 79, 442, 629, 711, 712, 722, 725, 750, 751, 800, 801, 809, 811, 864, 900, 928, 931, 990