RHEL 6:mysql(RHSA-2012:0874)

low Nessus プラグイン ID 59591

概要

リモート Red Hat ホストに 1 つ以上のセキュリティ更新がありません。

説明

1つのセキュリティの問題を修正し、1つの拡張機能を追加した更新版の mysql パッケージが、 Red Hat Enterprise Linux 6 用に現在利用可能です。

Red Hat セキュリティレスポンスチームは、この更新によるセキュリティ上の影響は小さいと評価しています。詳細な重要度評価を示す Common Vulnerability Scoring System(CVSS)ベーススコアは「参照」セクションの CVE リンクで入手できます。

MySQL は、マルチユーザー、マルチスレッドの SQL データベースサーバーで、MySQL サーバーデーモン(mysqld)と多数のクライアントプログラムおよびライブラリで構成されています。

MySQL がレコードの削除後に HANDLER READ NEXT ステートメントを処理する方法に欠陥が見つかりました。認証されたリモートの攻撃者がこの欠陥を利用して、mysqld がクラッシュするようなリクエストを提供する可能性があります。
クラッシュ後に mysqld は自動的に再起動するので、問題は一時的なサービス拒否が発生するのみとなります。(CVE-2012-2102)

この更新により、次の拡張機能も追加されます:

* InnoDB ストレージエンジンは、すべてのアーキテクチャに内蔵されています。この更新では、 32 ビット x86、AMD64、および Intel 64 アーキテクチャのプラグインとして InnoDB Plugin を InnoDB ストレージエンジンに追加します。このプラグインは、さらに機能を追加し、内蔵式 InnoDB ストレージエンジンを使用する場合よりも優れたパフォーマンスを提供します。プラグインの有効化に関する詳細は、参照セクションにリンクされた MySQL ドキュメントを参照してください。(BZ#740224)

MySQL の全ユーザーは、バックポートされたパッチが含まれるこれらの更新済みパッケージへアップグレードし、この拡張機能を追加してこの問題を修正する必要があります。
この更新のインストール後、 MySQL サーバーデーモン(mysqld)が自動的に再起動します。

ソリューション

影響を受けるパッケージを更新してください。

関連情報

https://dev.mysql.com/doc/refman/5.1/en/replacing-builtin-innodb.html

https://access.redhat.com/errata/RHSA-2012:0874

https://access.redhat.com/security/cve/cve-2012-2102

プラグインの詳細

深刻度: Low

ID: 59591

ファイル名: redhat-RHSA-2012-0874.nasl

バージョン: 1.20

タイプ: local

エージェント: unix

公開日: 2012/6/20

更新日: 2021/1/14

サポートされているセンサー: Frictionless Assessment Agent, Frictionless Assessment AWS, Frictionless Assessment Azure, Nessus Agent

リスク情報

VPR

リスクファクター: Low

スコア: 3.6

CVSS v2

リスクファクター: Low

Base Score: 3.5

Temporal Score: 2.6

ベクトル: AV:N/AC:M/Au:S/C:N/I:N/A:P

現状ベクトル: E:U/RL:OF/RC:C

脆弱性情報

CPE: p-cpe:/a:redhat:enterprise_linux:mysql, p-cpe:/a:redhat:enterprise_linux:mysql-bench, p-cpe:/a:redhat:enterprise_linux:mysql-debuginfo, p-cpe:/a:redhat:enterprise_linux:mysql-devel, p-cpe:/a:redhat:enterprise_linux:mysql-embedded, p-cpe:/a:redhat:enterprise_linux:mysql-embedded-devel, p-cpe:/a:redhat:enterprise_linux:mysql-libs, p-cpe:/a:redhat:enterprise_linux:mysql-server, p-cpe:/a:redhat:enterprise_linux:mysql-test, cpe:/o:redhat:enterprise_linux:6

必要な KB アイテム: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list, Host/cpu

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2012/6/20

脆弱性公開日: 2012/8/16

参照情報

CVE: CVE-2012-2102

BID: 52931

RHSA: 2012:0874