Quagga < 0.99.18 BGPD の複数のサービス拒否脆弱性

medium Nessus プラグイン ID 59789
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモートサービスは、複数のサービス拒否の脆弱性の影響を受ける可能性があります。

説明

自己報告されたバージョン番号によると、リモートホストでリスンする Quagga の BGP デーモンのインストールが複数のサービス拒否の脆弱性による影響を受けています。

- 無効な形式のAS_PATHLIMITパス属性によって、サービス拒否の脆弱性が発生する可能性があります。(CVE-2010-1675)

- 無効な形式の拡張コミュニティ属性によって、サービス拒否の脆弱性が発生する可能性があります。(CVE-2010-1674)

ソリューション

バージョン0.99.18以降にアップグレードしてください。

関連情報

https://bugzilla.quagga.net/show_bug.cgi?id=637

https://bugzilla.quagga.net/show_bug.cgi?id=638

http://savannah.nongnu.org/forum/forum.php?forum_id=7142

http://web.archive.org/web/20120121070712/http://www.quagga.net/download/quagga-0.99.18.changelog.txt

プラグインの詳細

深刻度: Medium

ID: 59789

ファイル名: quagga_0_99_18.nasl

バージョン: 1.6

タイプ: remote

ファミリー: Misc.

公開日: 2012/6/29

更新日: 2018/11/15

依存関係: quagga_zebra_detect.nasl

構成: パラノイドモードの有効化

リスク情報

VPR

リスクファクター: Low

スコア: 2.7

CVSS v2

リスクファクター: Medium

Base Score: 5

Temporal Score: 3.7

ベクトル: AV:N/AC:L/Au:N/C:N/I:N/A:P

現状ベクトル: E:U/RL:OF/RC:C

脆弱性情報

CPE: cpe:/a:quagga:quagga

必要な KB アイテム: Quagga/Installed, Settings/ParanoidReport

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2011/3/21

脆弱性公開日: 2011/3/15

参照情報

CVE: CVE-2010-1674, CVE-2010-1675

BID: 46942, 46943