PHP 5.3.x < 5.3.15の複数の脆弱性

critical Nessus プラグイン ID 60085
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモートのWebサーバーは、複数の脆弱性の影響を受けるPHPバージョンを使用しています。

説明

バナーによると、リモートホストにインストールされている PHP のバージョンは 5.3.15 より前の 5.3.x です。そのため、以下の脆弱性の影響を受ける可能性があります。

- ファイル「main/streams/streams.c」の関数「_php_stream_scandir」に、未特定のオーバーフロー脆弱性があります。(CVE-2012-2688)

- 詳細不明なエラーが存在することにより、「open_basedir」制限をバイパスできる可能性があります。
(CVE-2012-3365)

ソリューション

PHPバージョン5.3.15以降にアップグレードしてください。

関連情報

http://www.php.net/ChangeLog-5.php#5.3.15

プラグインの詳細

深刻度: Critical

ID: 60085

ファイル名: php_5_3_15.nasl

バージョン: 1.10

タイプ: remote

ファミリー: CGI abuses

公開日: 2012/7/20

更新日: 2021/1/19

依存関係: php_version.nasl

リスク情報

VPR

リスクファクター: Medium

スコア: 5.9

CVSS v2

リスクファクター: Critical

Base Score: 10

Temporal Score: 7.4

ベクトル: AV:N/AC:L/Au:N/C:C/I:C/A:C

現状ベクトル: E:U/RL:OF/RC:C

脆弱性情報

CPE: cpe:/a:php:php

必要な KB アイテム: www/PHP

エクスプロイトの容易さ: No exploit is required

パッチ公開日: 2012/7/19

脆弱性公開日: 2012/7/19

参照情報

CVE: CVE-2012-2688, CVE-2012-3365

BID: 54612, 54638