Scientific Linux セキュリティ更新:SL3.x i386/x86_64 の seamonkey

high Nessus プラグイン ID 60630
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモート Scientific Linux ホストに 1 つ以上のセキュリティ更新がありません。

説明

CVE-2009-2404 nss regexp ヒープオーバーフロー

Moxie Marlinspike 氏は、証明書の共通名を一致させるのに使用される NSS ライブラリ(SeaMonkey 提供)の正規表現パーサーに、ヒープオーバーフローの欠陥があることを報告しました。悪意ある Web サイトが、ヒープオーバーフローを発生させ、注意深く細工された証明書を提示することが可能です。これにより、クラッシュが発生したり、 SeaMonkey を実行しているユーザーの権限で任意のコードが実行されたりする可能性があります。(CVE-2009-2404)

注:これ以上のユーザーインタラクションなしにこの問題を悪用するためには、注意深くに細工された証明書に SeaMonkey が信頼する認証局による署名が必要です。この署名がない場合、SeaMonkey は証明書が信頼されないものであることを被害者に警告します。
その後、ユーザーが証明書を受け入れた場合のみ、オーバーフローが発生します。

更新済みのパッケージのインストール後、この更新を有効にするために、SeaMonkey を再起動する必要があります。

ソリューション

影響を受けるパッケージを更新してください。

関連情報

http://www.nessus.org/u?ae73e964

プラグインの詳細

深刻度: High

ID: 60630

ファイル名: sl_20090730_seamonkey_on_SL3_x.nasl

バージョン: 1.5

タイプ: local

エージェント: unix

公開日: 2012/8/1

更新日: 2021/1/14

依存関係: ssh_get_info.nasl

リスク情報

VPR

リスクファクター: Medium

スコア: 5.9

CVSS v2

リスクファクター: High

Base Score: 9.3

ベクトル: AV:N/AC:M/Au:N/C:C/I:C/A:C

脆弱性情報

CPE: x-cpe:/o:fermilab:scientific_linux

必要な KB アイテム: Host/local_checks_enabled, Host/cpu, Host/RedHat/release, Host/RedHat/rpm-list

パッチ公開日: 2009/7/30

参照情報

CVE: CVE-2009-2404

CWE: 119