Scientific Linux セキュリティ更新:SL6.x i386/x86_64 の apr

medium Nessus プラグイン ID 61053
New! Vulnerability Priority Rating (VPR)

Tenable では、すべての脆弱性に対して動的な VPR が計算されます。VPR は脆弱性の情報を、脅威インテリジェンスや機械学習アルゴリズムと組み合わせて、攻撃時に最も悪用される可能性の高い脆弱性を予測します。詳細は、 「VPR とは何で、CVSS とはどう違うのか」を参照してください。

VPR スコア : 2.2

概要

リモート Scientific Linux ホストに 1 つ以上のセキュリティ更新がありません。

説明

Apache Portable Runtime(APR)は、Apache HTTP Server およびその他のプロジェクトで使用されるポータビリティライブラリです。これにより、C データ構造およびルーチンの無料のライブラリが提供されます。

CVE-2011-0419 の修正では、APR_FNM_PATHNAME 照合フラグが使用されたときに発生する apr_fnmatch() 関数の無限ループの欠陥が紹介されています。リモートの攻撃者がこの欠陥を利用して、apr_fnmatch() 関数を使用するアプリケーションでサービス拒否を引き起こすことが可能です。
(CVE-2011-1928)

注:この問題は、ワイルドカード URL を含む「Location」ディレクティブを使用している httpd 構成に影響を与えました。サービス拒否が通常の操作中に発生させる可能性があります。これは、悪意ある HTTP リクエストを特に必要としませんでした。

この更新は、apr_fnmatch() 関数の上書きにより発生した追加的な問題にも対処しています。これは、CVE-2011-0419 の欠陥に対処するために必要なものでした。

apr のすべてのユーザーは、これらの更新済みパッケージにアップグレードする必要があります。これには、この問題を修正する、バックポートされたパッチが含まれています。httpd などの apr ライブラリを使用するアプリケーションは、この更新を有効にするために再起動する必要があります。

ソリューション

影響を受ける apr、apr-debuginfo および/または apr-devel のパッケージを更新してください。

関連情報

http://www.nessus.org/u?0c0ec168

プラグインの詳細

深刻度: Medium

ID: 61053

ファイル名: sl_20110531_apr_on_SL6_x.nasl

バージョン: 1.10

タイプ: local

エージェント: unix

公開日: 2012/8/1

更新日: 2021/1/14

依存関係: ssh_get_info.nasl

リスク情報

リスクファクター: Medium

VPR スコア: 2.2

CVSS v2.0

Base Score: 4.3

ベクトル: AV:N/AC:M/Au:N/C:N/I:N/A:P

脆弱性の情報

CPE: x-cpe:/o:fermilab:scientific_linux

必要な KB アイテム: Host/local_checks_enabled, Host/cpu, Host/RedHat/release, Host/RedHat/rpm-list

パッチ公開日: 2011/5/31

参照情報

CVE: CVE-2011-0419, CVE-2011-1928