Scientific Linux セキュリティ更新:SL5.x i386/x86_64 の postgresql84

medium Nessus プラグイン ID 61154

概要

リモート Scientific Linux ホストに 1 つ以上のセキュリティ更新がありません。

説明

PostgreSQL は、高度なオブジェクトリレーショナルデータベース管理システム(DBMS)です。

Blowfish のハッシングを使用している時に crypt() 関数が PostgreSQL pgcrypto モジュールでパスワードの 8 ビット文字を処理する方法に符号の問題が見つかりました。非 ASCII 文字(高ビットセットの文字)の直前にある最大 3 つまでの文字が、ハッシュ結果に影響せず、有効なパスワードの長さが短くなります。これにより、いくつかの異なるパスワードが同じ値にハッシュ化されるため、ブルートフォース推測がより効率的になりました。(CVE-2011-2483)

注:CVE-2011-2483 の修正により、この更新内容をインストールした後、一部のユーザーは PostgreSQL crypt() 関数を使用して Blowfish によりハッシュされたユーザーパスワードをバックエンド PostgreSQL データベースに保存するアプリケーションにログインできない可能性があります。パスワードのハッシュプレフィックスを「$2x$」に変更することにより安全でないプロセスが特定のパスワードに対して再度有効となる可能性があります(これにより影響を受けるユーザーがログインできるようになります)。

これらの更新済みの postgresql84 パッケージは、PostgreSQL をバージョン 8.4.9 にアップグレードします。変更の完全なリストについては、「PostgreSQL リリースノート」を参照してください:

http://www.postgresql.org/docs/8.4/static/release.html

すべての PostgreSQL ユーザーは、これらの更新済みパッケージにアップグレードして、この問題を解決するすることが推奨されます。postgresql サービスが実行中の場合、この更新のインストール後に自動的に再起動されます。

ソリューション

影響を受けるパッケージを更新してください。

関連情報

https://www.postgresql.org/docs/8.4/release.html

http://www.nessus.org/u?f78efe70

プラグインの詳細

深刻度: Medium

ID: 61154

ファイル名: sl_20111017_postgresql84_on_SL5_x.nasl

バージョン: 1.6

タイプ: local

エージェント: unix

公開日: 2012/8/1

更新日: 2021/1/14

サポートされているセンサー: Nessus Agent

リスク情報

VPR

リスクファクター: Medium

スコア: 4.7

CVSS v2

リスクファクター: Medium

Base Score: 5

ベクトル: AV:N/AC:L/Au:N/C:P/I:N/A:N

脆弱性情報

CPE: x-cpe:/o:fermilab:scientific_linux

必要な KB アイテム: Host/local_checks_enabled, Host/cpu, Host/RedHat/release, Host/RedHat/rpm-list

パッチ公開日: 2011/10/17

参照情報

CVE: CVE-2011-2483