PHP 5.4.x < 5.4.11 cURL X.509 証明書ドメイン名一致 MiTM の弱点

medium Nessus プラグイン ID 63622

概要

リモート Web サーバーが使用するバージョンの PHP が、中間者攻撃に対して脆弱である可能性があります。

説明

バナーによると、リモートホストにインストールされている PHP 5.4.x のバージョンは、5.4.11 より前です。したがって、 cURL 拡張の弱点による影響を受ける可能性があり、 SSL なりすましや中間者攻撃が引き起こされる可能性もあります。

証明書の検証の試行時、cURL ライブラリ(libcurl)が、サーバーのホスト名が X.509 証明書の「Subject Common Name」(CN)または「SubjectAltName」のドメイン名と一致することを検証できません。

注意:このプラグインは、PHP インストールが cURL 拡張でビルドされているか否かの検証は行いません。その代りに、PHP の自己報告バージョン番号のみを参考にします。

ソリューション

PHPバージョン5.4.11以降にアップグレードしてください。

関連情報

http://www.php.net/ChangeLog-5.php#5.4.11

https://bugs.php.net/bug.php?id=63352

https://bugs.php.net/bug.php?id=63795

プラグインの詳細

深刻度: Medium

ID: 63622

ファイル名: php_5_4_11.nasl

バージョン: 1.6

タイプ: remote

ファミリー: CGI abuses

公開日: 2013/1/18

更新日: 2022/4/11

構成: パラノイドモードの有効化

リスク情報

CVSS v2

リスクファクター: Medium

Base Score: 4.3

ベクトル: AV:N/AC:M/Au:N/C:N/I:P/A:N

脆弱性情報

CPE: cpe:/a:php:php

必要な KB アイテム: www/PHP, Settings/ParanoidReport

パッチ公開日: 2013/1/17

脆弱性公開日: 2013/1/17