Apache 2.4.x < 2.4.4 複数の XSS 脆弱性

medium Nessus プラグイン ID 64893

概要

リモート Web サーバーは、複数のクロスサイトスクリプティング脆弱性の影響を受けることがあります。

説明

バナーによると、リモートホストで実行されている Apache 2.4.x のバージョンは、2.4.4 以前です。そのため、以下のクロスサイトスクリプティング脆弱性の影響を受けます。

- モジュールmod_info、mod_status、mod_imagemap、mod_ldap、mod_proxy_ftp 、およびエスケープ処理されていないホスト名およびURIに関連してエラーが存在することにより、クロスサイトスクリプティング攻撃をできることがあります。(CVE-2012-3499)

- mod_proxy_balancerモジュールのマネージャーインターフェイスに関連するエラーが存在することにより、クロスサイトスクリプティング攻撃をできることがあります。(CVE-2012-4558)

Nessus では、実際にはこれらの問題をテストしていませんが、その代わりにサーバーのバナーのバージョンに依存していることに、注意してください。

ソリューション

Apacheバージョン2.4.4以降にアップグレードしてください。あるいは、影響を受けるモジュールを絶対に使用しないでください。

関連情報

https://archive.apache.org/dist/httpd/CHANGES_2.4.4

http://httpd.apache.org/security/vulnerabilities_24.html

プラグインの詳細

深刻度: Medium

ID: 64893

ファイル名: apache_2_4_4.nasl

バージョン: 1.20

タイプ: combined

エージェント: windows, macosx, unix

ファミリー: Web Servers

公開日: 2013/2/26

更新日: 2022/4/11

構成: 徹底的なチェックを有効にする

サポートされているセンサー: Frictionless Assessment Agent, Frictionless Assessment AWS, Frictionless Assessment Azure, Nessus Agent

リスク情報

VPR

リスクファクター: Low

スコア: 3

CVSS v2

リスクファクター: Medium

Base Score: 4.3

Temporal Score: 3.2

ベクトル: AV:N/AC:M/Au:N/C:N/I:P/A:N

現状ベクトル: E:U/RL:OF/RC:C

CVSS スコアのソース: CVE-2012-4558

CVSS v3

リスクファクター: Medium

Base Score: 5.9

Temporal Score: 5.2

ベクトル: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: cpe:/a:apache:http_server

必要な KB アイテム: installed_sw/Apache

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2013/2/25

脆弱性公開日: 2013/2/18

参照情報

CVE: CVE-2012-3499, CVE-2012-4558

BID: 58165

CWE: 20, 74, 79, 442, 629, 711, 712, 722, 725, 750, 751, 800, 801, 809, 811, 864, 900, 928, 931, 990