Apache 2.2 < 2.2.24 の複数の XSS の脆弱性

medium Nessus プラグイン ID 64912

概要

リモート Web サーバーは、複数のクロスサイトスクリプティング脆弱性の影響を受けることがあります。

説明

バナーによると、リモートホストにインストールされている Apache 2.2 のバージョンは、2.2.24 より前です。そのため、以下のクロスサイトスクリプティング脆弱性の影響を受ける可能性があります。

- モジュール mod_info、mod_status、mod_imagemap、mod_ldap、mod_proxy_ftp 、およびエスケープ処理されていないホスト名および URI に関連してエラーが存在することにより、クロスサイトスクリプティング攻撃をできることがあります。(CVE-2012-3499)

- mod_proxy_balancer モジュールのマネージャーインターフェイスに関連するエラーが存在することにより、クロスサイトスクリプティング攻撃をできることがあります。(CVE-2012-4558)

Nessus では、実際にはこれらの欠陥をテストしていませんが、その代わりにサーバーのバナーのバージョンに依存していることに、注意してください。

ソリューション

影響を受けるモジュールが使用されていないことを確認するか、Apache バージョン 2.2.24 または以降にアップグレードしてください。

関連情報

https://archive.apache.org/dist/httpd/CHANGES_2.2.24

http://httpd.apache.org/security/vulnerabilities_22.html

プラグインの詳細

深刻度: Medium

ID: 64912

ファイル名: apache_2_2_24.nasl

バージョン: 1.19

タイプ: remote

ファミリー: Web Servers

公開日: 2013/2/27

更新日: 2018/6/29

リスク情報

VPR

リスクファクター: Low

スコア: 3

CVSS v2

リスクファクター: Medium

Base Score: 4.3

Temporal Score: 3.2

ベクトル: AV:N/AC:M/Au:N/C:N/I:P/A:N

現状ベクトル: E:U/RL:OF/RC:C

CVSS v3

リスクファクター: Medium

Base Score: 5.3

Temporal Score: 4.6

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: cpe:/a:apache:http_server

必要な KB アイテム: installed_sw/Apache

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2013/2/26

脆弱性公開日: 2013/2/18

参照情報

CVE: CVE-2012-3499, CVE-2012-4558

BID: 58165

CWE: 20, 74, 79, 442, 629, 711, 712, 722, 725, 750, 751, 800, 801, 809, 811, 864, 900, 928, 931, 990