MySQL 5.5 < 5.5.30 yaSSL バッファオーバーフロー

high Nessus プラグイン ID 65734
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモートのデータベースサーバーは、バッファオーバーフローの脆弱性の影響を受けます。

説明

リモートホストにインストールされている MySQL 5.5 のバージョンが 5.5.30 より前であるため、「yaSSL」に関連するバッファオーバーフローの影響を受けます。
このエラーにより、任意のコードが実行される可能性があります。

ソリューション

MySQL バージョン 5.5.30 以降にアップグレードしてください。

関連情報

https://www.zerodayinitiative.com/advisories/ZDI-13-251/

http://dev.mysql.com/doc/refman/5.5/en/news-5-5-30.html

https://dev.mysql.com/doc/relnotes/mysql/5.5/en/news-5-5-30.html

https://blogs.oracle.com/sunsecurity/cve-2012-0553-buffer-overflow-vulnerability-in-yassl

http://www.nessus.org/u?c79e27db

プラグインの詳細

深刻度: High

ID: 65734

ファイル名: mysql_5_5_30.nasl

バージョン: 1.7

タイプ: remote

ファミリー: Databases

公開日: 2013/3/29

更新日: 2019/11/27

依存関係: mysql_version.nasl, mysql_login.nasl

構成: パラノイドモードの有効化

リスク情報

CVSS スコアのソース: CVE-2013-1492

VPR

リスクファクター: Medium

スコア: 5.8

CVSS v2

リスクファクター: High

Base Score: 7.5

Temporal Score: 5.5

ベクトル: AV:N/AC:L/Au:N/C:P/I:P/A:P

現状ベクトル: E:U/RL:OF/RC:C

脆弱性情報

CPE: cpe:/a:oracle:mysql

必要な KB アイテム: Settings/ParanoidReport

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2013/2/5

脆弱性公開日: 2013/3/19

参照情報

CVE: CVE-2013-1492

BID: 58595