PHP 5.3.x < 5.3.27の複数の脆弱性

medium Nessus プラグイン ID 67259
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモート Web サーバーが使用するバージョンの PHP は、複数の脆弱性の影響を受ける可能性があります。

説明

バナーによると、リモートホストにインストールされている PHP 5.3.x のバージョンは、5.3.27 より前です。このため、以下の脆弱性の影響を受ける可能性があります。

- 関数「_pdo_pgsql_error」にバッファオーバーフローエラーがあります。(バグ#64949)

- ファイル「ext/xml/xml.c」の多くの関数にヒープ破損エラーが存在します。(CVE-2013-4113/バグ#65236)

注意:このプラグインは、これらの脆弱性を悪用しようとしませんが、その代わりにPHP の自己報告されたバージョン番号のみに依存します。

ソリューション

ベンダーのパッチを適用するか、PHP バージョン 5.3.27 または以降にアップグレードしてください。

関連情報

https://bugs.php.net/bug.php?id=64949

https://bugs.php.net/bug.php?id=65236

http://www.php.net/ChangeLog-5.php#5.3.27

プラグインの詳細

深刻度: Medium

ID: 67259

ファイル名: php_5_3_27.nasl

バージョン: 1.19

タイプ: remote

ファミリー: CGI abuses

公開日: 2013/7/12

更新日: 2021/1/19

依存関係: php_version.nasl

リスク情報

CVSS スコアのソース: CVE-2013-4113

VPR

リスクファクター: Medium

スコア: 5.9

CVSS v2

リスクファクター: Medium

Base Score: 6.8

Temporal Score: 5

ベクトル: AV:N/AC:M/Au:N/C:P/I:P/A:P

現状ベクトル: E:U/RL:OF/RC:C

脆弱性情報

CPE: cpe:/a:php:php

必要な KB アイテム: www/PHP

エクスプロイトの容易さ: No exploit is required

パッチ公開日: 2013/7/11

脆弱性公開日: 2013/7/4

参照情報

CVE: CVE-2013-4113

BID: 61128