Oracle Linux 3:postgresql(ELSA-2010-0427)

high Nessus プラグイン ID 68042
New! Vulnerability Priority Rating (VPR)

Tenable では、すべての脆弱性に対して動的な VPR が計算されます。VPR は脆弱性の情報を、脅威インテリジェンスや機械学習アルゴリズムと組み合わせて、攻撃時に最も悪用される可能性の高い脆弱性を予測します。詳細は、 「VPR とは何で、CVSS とはどう違うのか」を参照してください。

VPR スコア : 6.7

概要

リモート Oracle Linux ホストに、1 つ以上のセキュリティ更新がありません。

説明

Red Hat セキュリティアドバイザリ 2010:0427 から:

複数のセキュリティ問題を修正する更新済みの postgresql パッケージが、Red Hat Enterprise Linux 3 で現在利用可能です。

Red Hat セキュリティレスポンスチームは、この更新のセキュリティ上の影響は中程度であると評価しています。詳細な重要度の評価を提供する Common Vulnerability Scoring System (CVSS)のベーススコアが、「参照」セクションの CVE リンクの各脆弱性に対して利用可能です。

PostgreSQL は、高度なオブジェクトリレーショナルデータベース管理システム(DBMS)です。PL/Perl および PL/Tcl により、ユーザーは Perl および Tcl 言語で PostgreSQL 関数を書くことができ、デフォルトで信頼されるモードでインストールされます。信頼されるモードでは、オペレーティングシステムレベルのアクセスなどのある特定の操作が制限されます。

PostgreSQL が PL/Perl で書かれたスクリプトに権限チェックを強制する方法で、欠陥が見つかりました。PL/Perl 手続き言語が特定のデータベースに登録されていた場合、特別に細工された PL/Perl スクリプトを実行している認証済みのデータベースユーザーがこの欠陥を利用して、意図される PL/Perl の信頼されるモードの制限をバイパスすることにより、任意の Perl スクリプトがデータベースサーバーの権限で実行される恐れがあります。
(CVE-2010-1169)

Red Hat は、CVE-2010-1169 の欠陥を責任感を持って報告してくれた Tim Bunce に感謝の意を表します。

PostgreSQL が PL/Tcl で書かれたスクリプトに権限チェックを強制する方法で、欠陥が見つかりました。PL/Tcl 手続き言語が特定のデータベースに登録されていた場合、特別に細工された PL/Tcl スクリプトを実行している認証済みのデータベースユーザーがこの欠陥を利用して、意図される PL/Tcl の信頼されるモードの制限をバイパスすることにより、任意の Tcl スクリプトがデータベースサーバーの権限で実行される恐れがあります。
(CVE-2010-1170)

PostgreSQL が BIT() および BIT VARYING() SQL データタイプのためにビット文字列からサブ文字列を取得する方法で、バッファオーバーフローの欠陥が見つかりました。特別に細工された SQL クエリを実行している認証済みのデータベースユーザーがこの欠陥を利用して、一時的なサービス拒否(postgres デーモンクラッシュ)を引き起こしたり、データベースユーザーの権限で任意のコードを実行したりする恐れがあります。(CVE-2010-0442)

PostgreSQL が結合された関係のためにハッシュテーブルのサイズを計算するために使用する方法で、整数オーバーフロー欠陥が見つかりました。認証済みのデータベースユーザーが、特別に細工された SQL クエリを作成することにより、一時的なサービス拒否(postgres デーモンクラッシュ)を引き起こしたり、データベースユーザーの権限で任意のコードを実行したりする恐れがあります。(CVE-2010-0733)

データベースメンテナンス操作中のデータベーススーパーユーザーによるインデックス関数の実行中に、PostgreSQL が不適切にセッションローカルな状態を保護しています。認証済みのデータベースユーザーがこの欠陥を利用して、特別に細工されたインデックス関数を介して自らの権限を昇格する恐れがあります。(CVE-2009-4136)

PostgreSQL の全ユーザーは、バックポートされたパッチが含まれるこれらの更新済みパッケージへアップグレードし、これらの問題を修正することが推奨されます。更新を有効にするには、実行中の PostgreSQL のインスタンスを再起動(「service rhdb restart」)する必要があります。

ソリューション

影響を受ける postgresql パッケージを更新してください。

関連情報

https://oss.oracle.com/pipermail/el-errata/2010-May/001475.html

プラグインの詳細

深刻度: High

ID: 68042

ファイル名: oraclelinux_ELSA-2010-0427.nasl

バージョン: 1.11

タイプ: local

エージェント: unix

公開日: 2013/7/12

更新日: 2021/1/14

依存関係: ssh_get_info.nasl

リスク情報

リスクファクター: High

VPR スコア: 6.7

CVSS v2.0

Base Score: 8.5

Temporal Score: 6.7

ベクトル: AV:N/AC:M/Au:S/C:C/I:C/A:C

現状ベクトル: E:POC/RL:OF/RC:C

脆弱性の情報

CPE: p-cpe:/a:oracle:linux:rh-postgresql, p-cpe:/a:oracle:linux:rh-postgresql-contrib, p-cpe:/a:oracle:linux:rh-postgresql-devel, p-cpe:/a:oracle:linux:rh-postgresql-docs, p-cpe:/a:oracle:linux:rh-postgresql-jdbc, p-cpe:/a:oracle:linux:rh-postgresql-libs, p-cpe:/a:oracle:linux:rh-postgresql-pl, p-cpe:/a:oracle:linux:rh-postgresql-python, p-cpe:/a:oracle:linux:rh-postgresql-server, p-cpe:/a:oracle:linux:rh-postgresql-tcl, p-cpe:/a:oracle:linux:rh-postgresql-test, cpe:/o:oracle:linux:3

必要な KB アイテム: Host/local_checks_enabled, Host/OracleLinux, Host/RedHat/release, Host/RedHat/rpm-list

エクスプロイトが利用可能: true

エクスプロイトの容易さ: Exploits are available

パッチ公開日: 2010/5/19

脆弱性公開日: 2009/12/15

参照情報

CVE: CVE-2009-4136, CVE-2010-0442, CVE-2010-0733, CVE-2010-1169, CVE-2010-1170

RHSA: 2010:0427

CWE: 189