Amazon Linux AMI:python27(ALAS-2013-220)

medium Nessus プラグイン ID 70224
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモート Amazon Linux AMI ホストに、セキュリティ更新がありません。

説明

Python 2.6 から 3.4 までの SSL モジュール内の ssl.match_hostname 関数は、X.509 証明書の Subject Alternative Name フィールドにあるドメイン名の「\0」文字を適切に処理していません。これにより、中間者攻撃は、正当な証明機関が発行した細工された証明書を通じて、任意の SSL サーバーになりすますことができます。これは CVE-2009-2408 に関連する問題です。

ソリューション

「yum update python27」を実行してシステムを更新してください。

関連情報

https://alas.aws.amazon.com/ALAS-2013-220.html

プラグインの詳細

深刻度: Medium

ID: 70224

ファイル名: ala_ALAS-2013-220.nasl

バージョン: 1.6

タイプ: local

エージェント: unix

公開日: 2013/10/1

更新日: 2018/4/18

依存関係: ssh_get_info.nasl

リスク情報

VPR

リスクファクター: Low

スコア: 3.4

CVSS v2

リスクファクター: Medium

Base Score: 4.3

ベクトル: AV:N/AC:M/Au:N/C:N/I:P/A:N

脆弱性情報

CPE: p-cpe:/a:amazon:linux:python27, p-cpe:/a:amazon:linux:python27-debuginfo, p-cpe:/a:amazon:linux:python27-devel, p-cpe:/a:amazon:linux:python27-libs, p-cpe:/a:amazon:linux:python27-test, p-cpe:/a:amazon:linux:python27-tools, cpe:/o:amazon:linux

必要な KB アイテム: Host/local_checks_enabled, Host/AmazonLinux/release, Host/AmazonLinux/rpm-list

パッチ公開日: 2013/9/4

参照情報

CVE: CVE-2013-4238

ALAS: 2013-220