PHP 5.3.x < 5.3.28 の複数の OpenSSL 脆弱性

high Nessus プラグイン ID 71426
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモート Web サーバーが使用するバージョンの PHP は、複数の脆弱性の影響を受ける可能性があります。

説明

バナーによると、リモートホストにインストールされている PHP のバージョンは、5.3.x の 5.3.28 より前です。このため、以下の脆弱性の影響を受ける可能性があります。

- PHP OpenSSL 拡張のホスト名 ID 確認に欠陥があります。これは、NULL バイトがあるホスト名が含まれている証明書を処理するときに発生します。攻撃者は、この欠陥を悪用して、中間者攻撃を実行し、SSL サーバーでなりすます可能性があります。この問題を悪用するには、攻撃者は、クライアントが信頼する認証局によって署名済みの、注意深く作り上げられた証明書を取得する必要があることに、注意してください。(CVE-2013-4073)

- PHP OpenSSL 拡張の openssl_x509_parse() 関数が X.509 証明書を解析する方法に、メモリ破損欠陥が存在します。リモートの攻撃者は、この欠陥を使用して、悪意のある、自己署名された証明書または信頼できる認証局によって署名された証明書を、前述の関数を使って PHP アプリケーションに提供することがあります。これにより、アプリケーションがクラッシュすることがあり、場合によっては攻撃者が、PHP インタープリターを実行しているユーザーの権限で、任意のコードを実行できることがあります。(CVE-2013-6420)

このプラグインは、これらの脆弱性を悪用しようとしませんが、その代わりにPHP の自己報告されたバージョン番号のみに依存することに、注意してください。

ソリューション

PHP バージョン 5.3.28 または以降にアップグレードしてください。

関連情報

https://seclists.org/fulldisclosure/2013/Dec/96

https://bugzilla.redhat.com/show_bug.cgi?id=1036830

http://www.nessus.org/u?b6ec9ef9

http://www.php.net/ChangeLog-5.php#5.3.28

プラグインの詳細

深刻度: High

ID: 71426

ファイル名: php_5_3_28.nasl

バージョン: 1.17

タイプ: remote

ファミリー: CGI abuses

公開日: 2013/12/14

更新日: 2021/1/19

依存関係: php_version.nasl

リスク情報

CVSS スコアのソース: CVE-2013-6420

VPR

リスクファクター: Medium

スコア: 6.7

CVSS v2

リスクファクター: High

Base Score: 7.5

Temporal Score: 5.9

ベクトル: AV:N/AC:L/Au:N/C:P/I:P/A:P

現状ベクトル: E:POC/RL:OF/RC:C

CVSS v3

リスクファクター: High

Base Score: 7.3

Temporal Score: 6.6

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

現状ベクトル: E:P/RL:O/RC:C

脆弱性情報

CPE: cpe:/a:php:php

必要な KB アイテム: www/PHP

エクスプロイトが利用可能: true

エクスプロイトの容易さ: No exploit is required

パッチ公開日: 2013/12/12

脆弱性公開日: 2013/6/27

参照情報

CVE: CVE-2013-4073, CVE-2013-4248, CVE-2013-6420

BID: 60843, 61776, 64225

EDB-ID: 30395