OpenSSL 1.0.0 < 1.0.0m の複数の脆弱性

high Nessus プラグイン ID 73403

概要

リモートサービスは、複数の脆弱性の影響を受けます。

説明

バナーによると、リモート Web サーバーで 1.0.0m より前のバージョンの OpenSSL 1.0.0 が使用されています。このため、この OpenSSL ライブラリは、報告されているところによれば、以下の脆弱性の影響を受けます。

- 関数「ssl3_read_bytes」にエラーがあり、これにより、他のセッションにデータを注入できることや、サービス拒否攻撃をできることがあります。この問題を悪用できるのは、「SSL_MODE_RELEASE_BUFFERS」が有効な場合のみであることに注意してください。(CVE-2010-5298)

- 楕円曲線デジタル署名アルゴリズム (ECDSA)の実装に関連するエラーがあることにより、「FLUSH+RELOAD」キャッシュのサイドチャネル攻撃を介してnonceを漏えいできることがあります。(CVE-2014-0076)

- 無効な DTLS フラグメント処理に関連するバッファオーバーフローエラーがあることにより、任意のコードが実行されることがあります。この問題がOpenSSLに影響するのは、DTLSクライアントまたはサーバーとして使用されている場合のみであることに、注意してください。(CVE-2014-0195)

- 関数「do_ssl3_write」にエラーが存在するため、NULL ポインターが逆参照され、サービス拒否攻撃が実行される可能性があります。この問題が悪用可能なのは、「SSL_MODE_RELEASE_BUFFERS」が有効な場合のみであることに、注意してください。(CVE-2014-0198)

- DTLS ハンドシェイク処理に関連するエラーがあることにより、サービス拒否攻撃が実行されることがあります。この問題が OpenSSL に影響するのは、DTLS クライアントとして使用される場合のみであることに、注意してください。
(CVE-2014-0221)

- 未特定のエラーがあることにより、攻撃者が、弱い鍵素材を使用させることで、中間者攻撃を簡略化できることがあります。
(CVE-2014-0224)

- 匿名の ECDH 暗号化パッケージに関連する未特定のエラーがあることにより、サービス拒否攻撃をできることがあります。この問題の影響を受けるのは、OpenSSL TLSクライアントのみであることに注意してください。(CVE-2014-3470)

- デコードするときに、base64 でエンコードされた入力の不適切な検証により、EVP_DecodeUpdate() 関数に整数アンダーフロー状態が存在します。これにより、リモートの攻撃者が、悪意をもって細工されたbase64データを使って、セグメンテーション違反またはメモリ破損を引き起こして、サービス拒否を発生させたり、任意のコードを実行したりすることが可能です。(CVE-2015-0292)

ソリューション

OpenSSL 1.0.0m 以降にアップグレードしてください。

参考資料

https://www.openssl.org/news/secadv/20140605.txt

https://www.openssl.org/news/secadv/20150319.txt

http://eprint.iacr.org/2014/140

http://www.openssl.org/news/vulnerabilities.html#CVE-2010-5298

https://www.openssl.org/news/vulnerabilities.html#2014-0076

http://www.openssl.org/news/vulnerabilities.html#CVE-2014-0198

https://www.openssl.org/news/vulnerabilities.html#CVE-2014-0221

http://www.openssl.org/news/vulnerabilities.html#CVE-2014-0224

http://www.openssl.org/news/vulnerabilities.html#CVE-2014-3470

http://ccsinjection.lepidum.co.jp/

https://www.imperialviolet.org/2014/06/05/earlyccs.html

プラグインの詳細

深刻度: High

ID: 73403

ファイル名: openssl_1_0_0m.nasl

バージョン: 1.23

タイプ: combined

エージェント: windows, macosx, unix

ファミリー: Web Servers

公開日: 2014/4/8

更新日: 2023/8/21

サポートされているセンサー: Nessus Agent, Nessus

リスク情報

VPR

リスクファクター: High

スコア: 7.7

CVSS v2

リスクファクター: High

Base Score: 7.5

Temporal Score: 6.2

ベクトル: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

CVSS スコアのソース: CVE-2015-0292

脆弱性情報

CPE: cpe:/a:openssl:openssl

必要な KB アイテム: installed_sw/OpenSSL

エクスプロイトが利用可能: true

エクスプロイトの容易さ: Exploits are available

パッチ公開日: 2014/4/7

脆弱性公開日: 2014/2/24

エクスプロイト可能

Core Impact

参照情報

CVE: CVE-2010-5298, CVE-2014-0076, CVE-2014-0195, CVE-2014-0198, CVE-2014-0221, CVE-2014-0224, CVE-2014-3470, CVE-2015-0292

BID: 66363, 66801, 67193, 67898, 67899, 67900, 67901, 73228

CERT: 978508