PHP 5.4.x < 5.4.28 の FPM の Unix ソケットのセキュアでない権限昇格

high Nessus プラグイン ID 73862
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモート Web サーバーが使用しているバージョンの PHP は、権限昇格脆弱性の影響を受ける可能性があります。

説明

バナーによると、リモートホストにインストールされている PHP 5.4.x のバージョンは、5.4.28 より前です。これは、権限昇格脆弱性の影響を受ける可能性があります。

Unix ソケットへの権限を設定するとき、FastCGI Process Manager(FPM)内に欠陥が存在します。これにより、リモートの攻撃者が、ソケットへのアクセス権を取得した後、上位の権限を取得できることがあります。

このプラグインは、この問題を悪用しようとしませんが、その代わりに PHP の自己報告されたバージョン番号のみに依存することに、注意してください。

ソリューション

PHP バージョン 5.4.28 または以降にアップグレードしてください。

関連情報

http://www.php.net/ChangeLog-5.php#5.4.28

https://bugs.php.net/bug.php?id=67060

http://www.nessus.org/u?a7b8dfdd

プラグインの詳細

深刻度: High

ID: 73862

ファイル名: php_5_4_28.nasl

バージョン: 1.9

タイプ: remote

ファミリー: CGI abuses

公開日: 2014/5/5

更新日: 2021/1/19

依存関係: php_version.nasl

リスク情報

CVSS スコアのソース: CVE-2014-0185

VPR

リスクファクター: Medium

スコア: 5.9

CVSS v2

リスクファクター: High

Base Score: 7.2

Temporal Score: 5.3

ベクトル: AV:L/AC:L/Au:N/C:C/I:C/A:C

現状ベクトル: E:U/RL:OF/RC:C

脆弱性情報

CPE: cpe:/a:php:php

必要な KB アイテム: www/PHP

エクスプロイトの容易さ: No exploit is required

パッチ公開日: 2014/5/1

脆弱性公開日: 2014/4/12

参照情報

CVE: CVE-2014-0185

BID: 67118