Apache Tomcat 6.0.x < 6.0.40 の複数の脆弱性

medium Nessus プラグイン ID 74245
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモートの Apache Tomcat サーバーは複数の脆弱性の影響を受けます。

説明

自己報告されたバージョン番号によると、リモートホストでリッスンしている Apache Tomcat 6.0.x のインスタンスは、6.0.40 より前のバージョンです。したがって、次の脆弱性の影響を受けます:

- チャンクサイズとチャンク形式のリクエストに関連するエラーが存在します。これにより、DoS 攻撃(サービス拒否攻撃)が引きこされる可能性があります。
(CVE-2014-0075)

- XSLT の処理およびセキュリティマネージャーに関連するエラーが存在し、これにより外部 XML エンティティに関してセキュリティ機能がバイパスされる可能性があります。(CVE-2014-0096)

- リバースプロキシの背後でアプリケーションを処理し、使用する Content-Length ヘッダーに関連するエラーが存在するため、セキュリティ機能がバイパスされる可能性があります。(CVE-2014-0099)

エラーが存在するため、悪意ある Web アプリケーションによって、XML パーサーのアプリケーションへ望ましくない注入が行われる可能性があります。また、セキュリティコントロールの回避、外部 XML エンティティの処理が可能になります。
(CVE-2014-0119)

Nessus はこれらの問題に対してテストされていませんが、その代わりにアプリケーションの自己報告されたバージョン番号のみに依存していることに、注意してください。

ソリューション

Apache Tomcat バージョン 6.0.41 または以降にアップグレードしてください。

注意:バージョン 6.0.40 がこれらの問題を修正しましたが、このバージョンはけっして公式にはリリースされず、ベンダーは 6.0.41 以降にアップグレードすることを推奨しています。

関連情報

http://tomcat.apache.org/security-6.html#Fixed_in_Apache_Tomcat_6.0.41

プラグインの詳細

深刻度: Medium

ID: 74245

ファイル名: tomcat_6_0_41.nasl

バージョン: 1.13

タイプ: combined

エージェント: windows, macosx, unix

ファミリー: Web Servers

公開日: 2014/5/30

更新日: 2020/3/11

依存関係: tomcat_error_version.nasl, tomcat_win_installed.nbin, apache_tomcat_nix_installed.nbin

リスク情報

CVSS スコアのソース: CVE-2014-0119

VPR

リスクファクター: Medium

スコア: 4.2

CVSS v2

リスクファクター: Medium

Base Score: 4.3

Temporal Score: 3.2

ベクトル: AV:N/AC:M/Au:N/C:P/I:N/A:N

現状ベクトル: E:U/RL:OF/RC:C

CVSS v3

リスクファクター: Medium

Base Score: 5.3

Temporal Score: 4.6

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: cpe:/a:apache:tomcat

必要な KB アイテム: installed_sw/Apache Tomcat

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2014/5/23

脆弱性公開日: 2014/5/17

参照情報

CVE: CVE-2014-0075, CVE-2014-0096, CVE-2014-0099, CVE-2014-0119

BID: 67667, 67668, 67669, 67671